Electrical Board Issue

Team 240 is having an issue with our electrical board and any advice on what could be the problem is greatly appreciated.

We have two robots that we are building and we finished both electrical boards and programming is working with the drive train. We get the practice robot over to programming and we noticed the robot veers to the right. So after we noticed the problem we go to test each talon individually. We found that one of our right drive train motors only goes backwards! After this we instantly go to troubleshooting the problem. First we tried a new talon (same issue). Then, we test the can wires and went through all of them making sure the connections were good. STILL the same problem with the talon! We even ended up switching both CAN busses with new ones to see if the issue lies there and nothing changed. Now we put the same code onto the other robot to see if it’s a code issue and the robot worked fine, but only on the second robot. We’ve also changed the Roborio to see if that was the issue and we still get the same problem. The right drive talon will only go backwards and won’t go forward. The talon will light up green indicating that the motor should be going forward but it doesn’t. One day the talon even started to smell bad and we opened it up and the inside wasn’t looking to good. So we had to put in a new talon in its place. We went through every wire by wire and compared both robots to make sure everything was exactly the same (and it is). For some reason, whether if we change the rio, talon, or can bus the issue still stands.

Does anyone have an idea of what could be going on? Any input would be greatly appreciated. Thank you!

Make sure all wires are connected with correct polarity, though this shouldn’t make the motor only move one way. Check the code and make sure the motor values are not negative for both directions. Try a different motor in its place and see what happens. Any pictures?

Did you ensure to update to the latest firmware on all your talons?

We have gone through all polarities. Whether it be through power from the PDP to the can bus with high (yellow) low (green) and also on the outputs to the motor (green with black) and (white with red). We also used a brand new motor to test the talon and it still only goes backwards. We tested the real right drive motor by itself and it will indeed move both ways.

I don’t have pictures but I can get a picture of the talon that went bad and put it up tomorrow.

Talon firmware has also been updated

Thank you guys for the input! Greatly appreciated

Have you tried swapping the PDP and VRM? What happens if you try the normal motor in place of the reversed motor with the same Talon? Or try the normal motor on the Talon for the reversed motor?

Would the PDP or VRM have an effect on the motors only going backwards? The talon gets the power from the PDP perfectly fine. We tried a new fuse and even put it in a different spot on the PDP and the problem remained.

We got a new motor and ran it off the same talon and had the same problem. We tested both the regular motor and the new test motor directly through a simple test board with a switch and they ran fine.

It’s definitely testing our minds over here because both motors work fine yet when we apply the code and run it individually the motor only works backward.

The same code was ran on our second (competition) robot and it runs perfectly fine

Try this:

Only put 3 items on the CAN Bus: RoboRio, PDP, and the problem drive Talon. Ideally, you will use the ROBORio and PDP from the working robot (since those are presumably good).

Does it work?
If so, add back one Talon at a time.
Rinse, repeat.

It could be one of the other CAN Bus items causing problems with the problem talon.

Another good test is to switch the CAN IDs of one of the good talons and one of the bad ones. If the problem stays with the same Talon, it’s a hardware problem. If it moves, it’s software.

Problems with the CAN buss will not affect direction of one controller. VEX recommends that users update firmware to the latest version or at least ver. 1.1 for CAN users. It is always possible that the firmware has become corrupt and is only affecting direction.
I have to ask, does the controller drive the motor when the throttle is at rest?

Thank you all for the input! We will definitely give everything a try. I will let you know how everything goes!

The controller does not drive the motor when the throttle is at rest

Thank you all again for your input! Greatly appreciated

I’d also check to make sure there’s nothing in the pins of the Talon… there could be something that bridges the forward limit switch and ground pins which wouldn’t allow the motor to move one direction. Work with programming on this, as they should be able to see if the forward limit is set to true or not. (I’m not a programmer but I’ve seen the driver station receive this feedback before)

If not, try wiring the Talon using PWM control and see if you have the same issue.

If these don’t work, send me a private message and 4611 will be happy to help.
Good luck.

I think it’s highly unlikely that the PDP and/or VRM could cause this, but I don’t know what else to check at this point, except maybe the radio. Make sure you use a full battery. As suggested above, check all pins and make sure they’re clean. Maybe switch the left and right sides in software(set left to be right and vice versa), and see what happens.

The fastest way to determine why a Talon SRX is not acting as expected is to check the Self-Test while its behavior doesn’t match your exception. See Section 2.4 in the Talon SRX Software Reference Manual for how to do this. A screenshot of that and the current settings/firmware from the web-based config would be best.

Also we generally recommend making sure there are no compounding errors in your Driverstation message output.

If the Talon is reporting driving voltage in the forward direction (green LEDs or selt-test), use a voltmeter to measure the output voltage of the motor controllers. Be certain the voltmeter is wired for voltage mode (not current nor continuity).

If the Talon is not reporting driving voltage in the forward direction, you have a software or configuration issue.

Have you Re-checked the CAN ID numbers, on both Robots?
You said your competition bot works correctly. Poll the SRX’s and match them to your practice bot. When your guys swapped the SRX it would be easy to not reset the ID number.

We carefully labeled our drive motors and Talon SRX controllers. The kids took things apart, to grease the gearboxes. They did a total brain dump on assembly, and, completely mixed up the motors and controllers. It happens.

Sorry for not responding right away super busy with the season.

Good news! We fixed the problem! Turns out we had to replace a new talon and a new motor. We had to start fresh with both motor and controller. Now our robot goes forward and backward with ease.

On behalf of team 240 we are very grateful for all the help! The robotics community is truly amazing!

Thank you all!

Make sure you label and quarantine the motor and motor controller so you don’t inadvertently install them, say at a tournament, or loan them to someone looking for a spare.