Enabling yields one "Watchdog not fed" flash

Hi, our robot’s been on the blocks for a week or two being built and the electronics board being redesigned; I’ve edited the code quite a bit during that time. We just tested it, and we’re having a strange problem. After deploying the code, when we press “Enable,” the status bar changes to “Watchdog not fed” for one second then changes back to tele-operated enabled. We’ve also noticed that the digital sidecar’s 5V light goes out when this happens. I can only think that is a side affect of the watchdog. We also get regular “Watchdog failure system xxxx user xxxx” in the diagnostics. I feed the watchdog in my tele-operated vi, and even tried putting it in the < than 10 milliseconds timed tasks. Still one flash of watchdog not fed. Any ideas on what could be the problem?

Thanks in Advance! -2779

Do you have a problem with power? Maybe the loss of connection comes from an overdraw, explaining why the 5v light flashes – is the battery fully charged?

Regarding the first “Watchdog not fed” message - we see that first one too. So far it hasn’t affected the function of the robot. That one is a mystery to me too (we’ve seen it all through Beta test as well, but have brushed it off because it hasn’t ever affected the function). We were guessing it’s just the code transitioning between states that causes the temporary not-fed issue.

Regarding the system / user error in diagnostics, this is a known bug they are working on. Again - it shouldn’t affect your actual robot function

If the +5 LED goes out, you probably have a power problem. Is the Digital Sidecar getting a good 12 volts from the Power Distribution board?

The first watchdog message you see might be coming from a timing glitch at the beginning of the camera code. If it only happens the one time, don’t worry about it. The other occasional messages you see when you’re on the Diagnostic tab are also something you don’t need to worry about. (There might be a Driver Station software update that addresses them eventually.)

Yep, turns out the power was wrong (switched around). Issue solved. Thanks.