Encoder Feedback in BDC-COMM

We’ve been unable to receive any encoder data using the BDC-COMM utility. We’re currently running BDC-COMM 107 with Jaguar firmware version 107. We hooked up an E4P http://usdigital.com/products/encoders/incremental/rotary/kit/E4P (E4P-360-250-N-S-D-D-2) encoder to the Jaguar and established communications with it via BDC-COMM. Suspicious of poor disc alignment or bad connections in our circuitry, so we measured the encoder output with an oscilloscope and confirmed a square wave signal coming off of the appropriate lines. Next, testing the connectors off of the encoder lines, we sequentially took things apart to the point where the lines (which we’d confirmed the signal on) were gator-clipped into the pins of the jaguar’s encoder input. To be clear, these are the connections we made.

+5VDC -> ‘+’

Ch A -> ‘A’

Gnd -> ‘-‘

Ch B -> ‘B’

From the software side of things, we’re sure we have communications with the Jaguar (we can read temperature, voltage out, and current out in real-time, and drive motors in these modes), we’ve specified the number of encoder lines (360), and we’ve tried both reference settings (encoder, which should use only the ‘A’ channel, and quadrature encoder, which should use both ‘A’ and ‘B’).

With this setup, we’ve tried both spinning the encoder by hand and running it on a gearbox. In BDC-COMM, the values associated with the encoder output (speed, position) remain firmly at zero.

Any thoughts as to what we might check next?

Have you set the encoder counts/rev? The default value is 0 and unless you set this to a number, you will always read a 0 speed.

You need to set the mode to Speed Mode for the encoder speed to display. Switch back to whichever mode you want to control it in and you should now see the speed reported.