Encoders not working with characterization tools

Hello,
My team has been having trouble getting the Robot Characterization software to run correctly. The encoders don’t seems to be correctly outputting data. They are not updating in Shuffleboard and they just listed with a very small decimal. The characterization tool then says the robot has not moved (See image) and the the analysis mode shows that everything has been recorded as 0.
bad

Here’s the config:
https://gist.github.com/BobSaidHi/c28268692f0720618416ee7e3181a677

Here’s the project it generated:
https://github.com/frc6506/FRC-Robot-Characterization-2021

The one thing we have not tried yet is to use Python 3.7 (3.7.9) instead of Python 3.8. We have also not tried modifying the generated project to print/log all of the variables. Instead, we have been relying on what the generated project tells us.

Any help would be much appreciated.

Edit1: Fixed GitHub Gist for config file.

What version of the characterization tool are you using? There was a bug fixed in the release a day or two ago that fixed the encoders reporting 0.

1 Like

Pip reports it as 2021.1.3:

Name: frc-characterization
Version: 2021.1.3
Summary: FRC Characterization Library
Home-page: https://github.com/wpilibsuite/robot-characterization
Author: Eli Barnett, Dustin Spicuzza
Author-email: emichaelbarnett@gmail.com, dustin@virtualroadside.com
License: UNKNOWN
Location: c:\users[REDACTED]\appdata\local\programs\python\python38\lib\site-packages
Requires: argcomplete, pynetworktables, frccontrol, statsmodels, console-menu, pint, control, numpy, matplotlib, mako
Required-by:

Edit1: Finished writing, formatting

The latest version of frc-characterization is 2021.2.4.

1 Like

Thanks for the help!
It turns out that the latest version of the frc-characterization tool was published for Python 3.7 and is not available for Python 3.9. We fixed the issues by specifying Python 3.7 and getting the latest version of the tool.

I think you tried multiple things simultaneously. My understanding is that the latest frc-characterization release does work on Python 3.9.