Error imaging cRIO

We’ve been trying to re-image our cRIO so we can practice coding in Java on our 2014 robot. Right now, we have it connected to the PC through the wireless bridge, and we’ve checked the IP address settings. When we try to image, it starts the process, but then aborts with the following error message:

Unable to complete operation because of unexpected error:
Error 7 occurred at File/Directory Info in
NI_InternetTK_FTP_VIs.lvlib:FTP
[STOR].vi->NI_InternetTK_FTP_VIs.lvlib:FTP Store
Multiple.vi->ConfigUtility.lvlib:FRC 2012_FTP Put
File.vi->ConfigUtility.lvlib:CloseAndUploadRemoteConfiguration.vi->ConfigUtility.lvlib:CurrentLanguageConfig.vi->ConfigUtility.lvlib:ReImageTarget.vi->ConfigUtility.lvlib:Dialog.vi

Possible reason(s):

LabVIEW: File not found. The file might be in a different location or
deleted. Use the command prompt or the file explorer to verify that
the path is correct.

C:\Users\River\AppData\Local\Temp\lvtemporaryd_494320\FRC_ImageVersion.ini

Error 7 means some installation files are corrupted, missing or misplaced, i.e., file not found or file permissions are restricted, as in some school security managed computers.
It also comes up sometimes when a file system is copied from one PC to another instead of being installed and the new directory tree breaks some shortcuts.

The most common general solution is to uninstall and reinstall the files, such as the FRC Java specific update or the basic FRC java installation itself.
If another computer is available, then it can be worthwhile to install the FRC Java package on it and try from a clean installation.

By the way, if your cRIO has already been imaged with v52 from LabVIEW, then you only have to select java as the target language. You don’t have to reimage the cRIO with v52 again.

The imaging tool retrieves and updates FRC_ImageVersion.ini from the cRIO via FTP. The message you are getting is complaining that it do that. Make sure you don’t have a firewall that is blocking either the imaging tool or FTP.

Mark:

  1. How would we select Java as the target language?
  2. The FRC Java package refers to the Netbeans plugins, right?

Joe:

  1. The firewall on the computer is disabled. That should be sufficient, right?

Thanks for the help.

You may have been doing this already.
It’s just that “re-imaging” or re-formatting the cRIO is unnecessary.
It doesn’t hurt. It just takes longer and adds more opportunity for problems to occur.
In the cRIO Imaging Tool just pick Java as the Development Environment and Apply. Don’t choose Format Controller.

Error 7 is a Windows error that just means it cannot locate a file that it should. Usually that means that when the file was attempted to be written to your PC disk that it got blocked by something (directory privileges, anti-virus, firewall) or it was corrupted or dropped altogether during a software install.
So the Java FRC plugins are possible, but I think Joe’s idea of FTP getting blocked by something should be pursued first.

In addition to the firewall, disable any anti-virus programs that might interfere with ftp’ing files.





At this point, we’ve already done a reset of the crio (by holding down the reset button), so that probably means we have to image it from scratch, right? Should we try reinstalling the FRC Java plugins (or the NI Suite?) with the firewall and anti-virus disabled?

The reset button on the cRIO just reboots the device. It doesn’t wipe anything out.
So re-formatting still shouldn’t be necessary.
You can start the cRIO Imaging Tool and it should tell you if the cRIO is imagined correctly (look under “Current Image” at the top right = FRC_2014_v52).

First try disabling the anti-virus and anything else you know of that protects your PC from FTP copies.
Then use the cRIO Imaging Tool to set it to Java again.

Sounds good. We’re meeting Tuesday, so I’ll take another try at it and update you then. I’ll get some screenshots of the imaging software. Is there anything else that would be helpful for debugging? Thanks for all your help.

If the error still occurs after turning off the protection services, then browse to the directory path given in the error (it’ll be different each time but ~ C:\Users\River\AppData\Local\Temp\lvtemporaryd_494 320) to see if it’s really there and try creating or copying a file to that directory just to test your access privileges.

By the way remember to turn your firewall and anti-virus back on afterwards if this PC gets used to connect to the Internet.

P.S.
When you go looking for the missing file you may find that the directory itself is not there. Anti-virus or directory privileges may be preventing the creation of the temporary directory itself. You can also test manually ftp’ing the file from the cRIO yourself to see if you get a block message, or if the file is somehow missing on the cRIO side.

Alright, now we’re getting some different errors. When we first turned everything on, it detected the cRio, but the image version was unknown and the current IP was 10.0.0.2 (see attached image ‘first’). We tried to image, and got the error “The specified address is unreachable. Ensure IP address is on the correct subnet.”

At this point, we booted the cRio up into safe mode by hitting the reset button for 5 seconds. The orange status light is blinking 3 times, then pausing, confirming that the cRio is in safe mode. Now, when we scan for the cRIO, it comes up with the IP address 10.41.44.2 and with the correct image version. We tried to just change the development environment to java without reimaging, and got the “Unknown Error” (image attached). We tried reimaging, and got the same error. Now, we rescan, and the IP is still 10.41.44.2 and the image version is still correct, but the modules are no longer detected (see image: “Safe Mode”).

Thanks in advance for any help.


Unknown Error Code.png




Unknown Error Code.png

It sounds like the imaging didn’t complete properly.
You’ll need to get the imaging process to run all the way through and finish cleanly.
The “unreachable” error is a problem encountered when the cRIO’s IP address gets changed partway through the imaging process and the PC can’t keep up with the IP change.
There are several workable solutions that all involve keeping the PC connected through the cRIO IP change.

The cleanest way to do it is to Ethernet the PC to the DLink, then Ethernet from the DLink to the cRIO and attempt to image that way. Usually the DLink acting as a switch can keep track of the change in IP along the hard-wired Ethernet pathway.

Error 15426 could be telling you that you have an extra network adapter enabled. When you are imaging the cRIO, make sure you have disabled the wireless network adapter. Go to the Manage Network Connections “folder”, right-click on each of the networks shown there except the wired one you are using to talk to the cRIO, and choose “Disable”.

We’ve tried re-imaging both connected directly to the cRio and connecting through the wireless bridge. We get that same error both ways.

I recall that it was very important that the subnet mask on the imaging computer be set to 255.0.0.0.

Once we did that, the cRIO was able to reconnect to the imaging computer after the reboot and then the installation of the image files would complete.

Ok the wpiscreensteps guide says 255.255.255.0, but we’ll give that a try tomorrow.

Yes, there are many references to 255.255.255.0, but 255.0.0.0 works best for us.

We have had trouble imaging in the past. We found this post and follow the instructions in the linked re-imaging guide. It was developed a couple of years ago, but it still works for the 2014 control system, with appropriate substitutions.

http://www.chiefdelphi.com/forums/showpost.php?p=1121944&postcount=9

I’ve had success overcoming imaging errors by using a crossover cable and connecting it straight from a computer to the cRIO.