Error imaging roboRIO

I’ve been attempting to reimage a 2020-imaged roboRIO with the new 2022 v3.0 firmware. I’m using a USB-A to USB-B cord plugged into the roboRIO and the computer. I keep gettiing an error in the middle of the reimaging process. This is the one I get most commonly:

. “Unspecified error” doesn’t tell me much about what’s happening, but here’s what I’ve tried:

  • Using a different computer
  • Disabling all firewalls, network adapters other than the tether, and antivrius software
  • Running as administrator
  • Booting the roboRIO in safe mode
  • Resetting roboRIO power
  • Reinstalling the entire NI FRC software package
  • Trying to image another roboRIo. The same error occurs
  • Just re-running the image process lol.
  • renaming the computer name to remove a dash (the fact that this could cause an issue is shocking)
  • removing literally ever other robot component from power besides the rio and pdp

I can’t use NI’s web interface since it relies on Microsoft Silverlight which is not available for download since October 2021.
Does anyone have any ideas or suggestions on what to try? I am out of ideas.

Are you sure it was a 2020 image? Silverlight stopped being used for the webdashboard in 2019.

What is the firmware version?

The firmware version on the roboRIO currently is 6.0.0f1. The formatting image I’m attempting to use is 2022 v3.0.

When connecting to in Internet Explorer, nothing shows up except a link (that doesn’t work) to download Microsoft Silverlight. In any other browser (I’ve tried Edge, Chrome, Firefox, and Vivaldi) I get this page (which is the same as that in IE except for the text at the top about a blocked plugin.

I ended up getting it working over Ethernet rather than USB — I think the usb cord may have been broken.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.