Error in WPILIB VSCode

I tried setting up the WPILIB environment at home to work on a bit of code, but when VSCode performed an initial build on the robot code I cloned off GitHub, this occurred. As I far as I can see, no one else in FRC has had this problem. In normal circumstances, online sources recommended appending _OLD to the name of the gradle cache folder, but I can’t even do that because “the folder is open or in use in another window.” Does anyone have any pointers?

> Executing task: gradlew deploy  -PteamNumber=4681 --offline  -Dorg.gradle.jav


FAILURE: Build failed with an exception.

* What went wrong:
Could not open cp_settings remapped class cache for 38rjcrq9a9wf95j64dx4wt8on (pped\settings_1lj7cuexo8f5uhuql7c6e9vqa\38rjcrq9a9wf95j64dx4wt8on\cp_settings27
> Could not open cp_settings generic class cache for settings file 'C:\Users\ch\workspace\2020 FIRST Rise\settings.gradle' (C:\Users\chainarong\.gradle\cachescp_settings27b7120d8bed45e60dd0b95b8e5ecea0).
   > Unexpected lock protocol found in lock file. Expected 3, found 0.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debugt full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 8s
The terminal process terminated with exit code: 1

Terminal will be reused by tasks, press any key to close it.

Have you tried to reboot and then rename?

Thanks, but I actually just wiped every trace of WPILib and VSCode I could find on the computer, including the .gradle files in C::…/Users/… and reinstalled everything.

Something did the trick because I’ve been able to build code and write new code and push it off to GitHub!

Nonetheless, what do you mean by reboot and rename?