Error while Implementing Gyro

Hi, So im currently working with an ADIS16448 when I encountered a strange error. I was inplementing the vendor library and now I have this error (listed below) I tried an offline download and it also failed. I was wondering If anyone had any idea for an alternative, or a solution to the listed error. Thanks in advance

Code:

Error:

The supplied phased action failed with an exception.
Could not resolve all dependencies for configuration ‘:compileClasspath’.
Using insecure protocols with repositories, without explicit opt-in, is unsupported. Switch Maven repository ‘WPI38c21ab6-aa8b-44bc-b844-8086c77f09ec_0Release(http://maven.highcurrent.io/maven)’ to redirect to a secure protocol (like HTTPS) or allow insecure protocols.

Error while bulilding:

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘C:\Users\mates\OneDrive\Documents\7737_RobotCode_2022\2022 Robot\2022 Robot Code\Robot_V5\build.gradle’ line: 82

  • What went wrong:
    Could not determine the dependencies of task ‘:jar’.

Could not resolve all dependencies for configuration ‘:runtimeClasspath’.
Using insecure protocols with repositories, without explicit opt-in, is unsupported. Switch Maven repository ‘WPI38c21ab6-aa8b-44bc-b844-8086c77f09ec_0Release(http://maven.highcurrent.io/maven)’ to redirect to a secure protocol (like HTTPS) or allow insecure protocols.

A vendor library is no longer required for the ADIS16448, it’s now included in WPILIb.

oh okay, so can i just call on that class whenever I want?

It’s in a different package but yes. ADIS16448_IMU (WPILib API 2022.4.1)