Error with Visual Studio Code with Deploying Code

Hi i’m with the C4 Robotics Team, and I need help, So basicaly I was trying to deploy code after imaging the roborio then I get this

Executing task: gradlew deploy -PteamNumber=3543“C:\Users\Public\frc2019\jdk” <

Configure project :
NOTE: You are using an ALPHA version of GradleRIO, designed for the 2019 Season!
This release uses the 2018 Core Libraries, however all tooling (GradleRIO + IDE support) is incubating for 2019
If you encounter any issues and/or bugs, please report them to

Task :discoverRoborio
Discovering Target roborio
admin @ Connected.
Reason: InvalidImageException
RoboRIO Image invalid! RoboRIO: 2019_v12, allowed: [2018_v16, 2018_v17, 2018_v18]
admin @ Connected.
Reason: InvalidImageException
RoboRIO Image invalid! RoboRIO: 2019_v12, allowed: [2018_v16, 2018_v17, 2018_v18]
1 other action(s) failed resolution.
1 other action(s) not started.
Run with --info for more details

Task :discoverRoborio FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:discoverRoborio’.

A failure occurred while executing
Target roborio could not be found at any location! See above for more details.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

3 actionable tasks: 1 executed, 2 up-to-date
The terminal process terminated with exit code: 1

Do you think theres a way to fix it?

1 Like

You’re using the alpha VSCode plugins. Download the installer here for your system and follow the instructions on screensteps for using it

Or you’re trying to use an old alpha project with the released vscode extension (likely the case due to the “gradlew” command line you posted). You need to create a new project using the 2019 release and copy your code into it.


For the download, that’s what I’ve been using the specific one it gave me from first.
Version: 1.30.1
Commit: dea8705087adb1b5e5ae1d9123278e178656186a
Date: 2018-12-18T18:12:07.165Z
Electron: 2.0.12
Chrome: 61.0.3163.100
Node.js: 8.9.3
V8: 6.1.534.41
OS: Windows_NT x64 10.0.17134

I have done that too

Based on that error, you’re still opening the old project. So make sure you are opening the proper project in vscode. In build.grade, you should have a line like id "edu.wpi.first.GradleRIO" version "2019.1.1" If its still version 2019.0.0-alpha-4, its an old project. You will have to create a new one, and copy just your code files.

Thank you so much Everyone, Now its to figure out my code :smile:

Hey, I’m having a nearly identical problem, but now that I’ve copied over the files, I’m getting errors that suggest the libraries somehow became uninstalled.
EX: The import com.kauailabs cannot be resolved [268435846]
Any suggestions? Thanks.

You need to install the third-party libraries into your project. See

I have the libraries downloaded, and when I use the manage vendor libraries command on the WPILib command palette, it says that they are there. However, the code isn’t acknowledging this. I tried checking for updates, but there were none. I also already tried re-downloading one of the libraries, but it didn’t come up under install.

Does a build work? Eg is it just intellisense in the IDE having an issue?

Sorry for the delay; I did manage to get the code working. I had copied over files that included the libraries, and that was screwing things up. Thanks for the help, though.