Errors with install of Eclipse

I followed the manual on screensteps about how to install Eclipse and the FRC 2015 Toolchains. I’ve got them installed, and when I compile a sample program it always generates the FRCUserProgram.out file just fine. However, I keep getting two errors: Program “g++” not found in PATH and Program “gcc” not found in PATH. Does anyone know how to get rid of these errors?

Try looking at this stackoverflow thread.

you need to add the g++ compiler to the PATH

Try uninstalling the toolchains, reboot, make sure that the toolchain installer is on your root drive, install the toolchains, then open Eclipse.

All right. It works now. Thanks for the help!

Just for so others know cause I just spent enough time trying things, what worked for me was:
download minGW ( and put it on the c drive (you only have to install the c++ gcc option when it asks you).
Add the bin folder in minGW to the environmental variable named path.
Open Eclipse and the error messages were gone!

Tried both suggestions posted here, still getting same error. Anyone fix this in another way?

I used the mingw installer and added to the path also. I’ve heard from some places that going to Window->Preferences->C/C+±>Build->Settings and then using Restore Defaults on the Discovery tab can help. Also, if you’ve changed your PATH you need to restart Eclipse for it to see.

Thanks for the guidance on this thread. Having the same problems on Windows 8 after following the instructions, I think. I’m a little mystified about how having the windows mingw toolchain installed (which would logically compile to x86 code) would help with the ARM toolchain needed for the roboRIO. Tried uninstalling the FRC toolchain AND the Eclipse FRC extensions, then re-installing both. No joy.

Note: This should not cause any errors if you are only doing FRC dev.
You can safely ignore them. If you are doing more than FRC dev, install G++ on your path via MinGW as already suggested.

Having said that, you can make them go away by prefixing the value listed in the error with “arm-frc-linux-gnueabi-”. I’m afraid I don’t remember where it is off the top of my head but can provide the exact value if you copy-paste the entire error.

The cause is eclipse CDT (C/C++ Developer tools) expects g++ to be on the PATH for global header parsing. However the FRC projects use their own version of g++ with a different name (arm-frc-linux-gnueabi-g++) and the global tools don’t realize it. It is only a problem if you are doing native development.

Somewhere in settings you need to tell Eclipse that the tool path is “c:\frc\bin” (or put it on the path). Once I added that I was able to build a sample robot.

However, the library is missing. so the link step fails. Actually it is in the WPI toolset, but the linker never sees it. Any ideas? Must be another path somewhere I need to update.

That warning is expected and can be safely ignored per this page:

Thanks - did try installing MinGW (did so) and adding c:\MinGW\bin\ to the path variable. Still didn’t fix that error. Good to know the libstdc++ error can be ignored, but would be nicer to not have the distraction for myself or team programmers. Continued guidance welcome.

Just in case anyone is having problems with the install, I actually wrote an automated installer for my own team. It needs the x86 JDK to be installed, cause it’s the 32 bit version of Eclipse for now, but it should get you the up and running at least.

Any word on this? I’ve installed Eclipse and the FRC Toolchain but I’m still getting the g++ and gcc not found in PATH error. It’s added to my PATH. I’ve tried setting defaults, and everything listed in that stackoverflow thread. Still getting the same error.

We have the same problem. After trying in vain to make it go away we just decided to ignore it. Everything appears to work just fine anyways. We’re actually not certain if the code is actually building when we say “build project”, or just running the error checkers and then failing with the “gcc not in path” errors before it actually compiles. Either way, it builds when we deploy, so it doesn’t really matter.

If it’s not showing up then check to make sure the compiler was even installed correctly. I tested out another install and found the same thing that other people here have said. The GCC not found error can be ignored if you’re only developing for RoboRIO and don’t plan to use your Eclipse install for desktop development also.

Alright, I got a couple programs running on a testbed. It seems the g++/gcc errors can be ignored.

We had this problem too. ::ouch::

Go to Window>Preferences>C/C++>Build>Settings

Under Settings, go to the Discovery tab. There will be an entry called “CDT GCC Built-in Compiler Settings”. Click it. The box below (Language Settings Provider Options) will have a text box with text like “${COMMAND} ${FLAGS}…”

Append “arm-frc-linux-gnueabi-” to the beginning. Press “Ok”.
Screenshot below: