Ever seen this serial port problem before???

I’ve been programming the Innovation First Robot Controllers for three years now and have never run into the problem that I started experiencing today.

When I plug the tether cable from the notebook serial port into the RC, I immediately get a “Basic Init Error”. I can proceed to download new code, but then have to unplug the cable from the RC before I can reset it. Again, as soon as I plug the cable in, I get an instant “Basic Init Error”.

This is really frustrating, because obviously I cannot get any debug info back.

I have tried three different RCs (2000’s, 20001’s and 2002’s) and the same thing happens on all of them. I have tried different tether cables to no avail.

Having never seen this before, I assume my notebook has started sending something non-kosher out the serial port. It is a Dell Latitude running Windows 2000 Professional, and I have administrative access.

Any (experienced) ideas?

Thanks!!

Aidan
:slight_smile:

I’m assuming you’ve never used this laptop to program an RC before?

On another mailing list that I subscribe to, there were reports that the serial ports of people’s Dell laptops wouldn’t work correctly. I just went back to find those messages when I noticed a new message was posted today. Maybe you will find this usefull

There was a thread some month ago about compatibility of Dell Laptops with Dynamic-C. I even managed to find a solution for myself and recomended it to the group.

Well, it’s time to review. I am using Dell Latitude C810 notebook (P3/1000, 512mb, Intel 815 mobile chipset). On a recent visit to Dell support site (http://support.dell.com), I noticed there is a new version of BIOS available (dated somewhere beginning of November). I am usually of the habit to keep my BIOS (at least) current, so I downloaded it.

To my avail, I just noticed that DC works straigth forward without any problems and without my workaround! May be some Dell support staff is lurking here and has seen our troubles!

So, to sum it up: If you have an Dell Laptop and are experiencing troubles communicating, try a recent BIOS upgrade. It worked for me, it solved some other problems relating to RS port, so it could work for you as well.

And here was his original post, that he refered to above

I have had the same problem with my Dell Latitude C810. The problem is that somehow the serial port driver sends binary 00’s even without anything running, and this happens under both Win2k and WinXP. I have not too many different laptops around to see what’s going on, may be the problem is with the Intel chipset they’re using.

I solve the problem with a little nice utility called PortMon, downloadable at http://www.sysinternals.com/ntw2k/freeware/portmon.shtml. In fact, just running it and then closing causes the serial port to behave correctly. It probably loads some serial driver. The only side effect of that is that is this driver prevents Win2k into enterin hybernation mode, but that’s not so big trouble.

However, you’d need USB-RS232 adapter if you need more ports out of your laptop (being it Dell or not).

The fact that you are seeing the basic init error whenever you aren’t sending something sounds like it could be related to a serial port that sends nulls when idle.

I hope this helps and keep us informed

Again, search before you post.

http://www.chiefdelphi.com/forums/showthread.php?s=&threadid=14647&highlight=init (about half way through the first page).

Thanks Joe! I’ll give that a try. My computer is indeed a C810.

As for the other thread… that was a different problem…

Were you able to find a fix for this?

Talk about irony, our sponsor provided us with a Dell lattitude c620 that does virtually the same thing. I don’t have admin access, but if you found a fix, I can give it back to them and have them apply it.

Thanks :slight_smile:

I have an idea of what the problem may be. The DTR line on the serial port is used to reset the PBASIC processor. Presumably the processor needs to be reset before programming, etc. I’ll bet that these laptops that are causing this are holding the DTR line in the wrong state when the Stamp software isn’t programming them. If any of you have the capability, try making a serial cable that does not connect pin 4 across. (or you could just cut the pin 4 out of the end of an existing cable’s connectors if you have a cable to sacrifice). This (hopefully) should allow you to debug (but it won’t allow you to program). If you can debug with a cable like this then the next step would be to make a cable that has a switch in the line for pin 4 that you’d just have to toggle to get in and out of programming mode.