Exiting Autonomous Mode

I wrote some code using the 2006-2007 Competition Template.
The code never exits the Autonomous function to transfer to the manual operation.

Is anyone else having this problem? If so, have you figured out what is wrong?

Have you updated the Master Code to version 7? If not, here’s the download link for that:
http://www.vexrobotics.com/docs/software/vex-master-v7.zip

Also, make sure you do not have a jumper clip on interrupt 5 - that makes it so it will only run autonomous. A jumper on interrupt 6 forces it to run only the operator control portion, so you could place one there and see if it’s a code problem or not.

No jumpers in place at all and I’m running V7.

I updated my V2 copy of Easy C last night, but haven’t reloaded code yet.

I doubt that that is the problem, but I’ll find out this afternoon.

No luck with the upgrade. Still not getting to the Manual operation section of my code. What a VEXing problem…

Hmm. Other than the transmitter not having the Drive mode set to 23, I can’t think of anything else.

  • Turn the transmitter on and hold down the Mode and Select buttons located next to the display until the menu is opened.
  • Press the Mode button until “DRIVE” is displayed.
  • Use the +/- buttons to set the Drive mode to 23.

If that doesn’t work, could you show the code?

I’ve got this to barebones.

Open the competition template.
Open the Autonomous block and put in a Print-To-Screen
Open the Operator block and put in a P-T-S
Build & Download
Open the Terminal window
Turn on the transmitter
Let me know what you see after 20 seconds.

And the real solution is…

Download the correct version of the Master Code!!!

There are two version of Master Code V7. One for EasyC and one for MPLAB.

Make sure you download the correct one.

Thanks go out to Rick Torrance for pointing this out to me and being so patient with me in the process.