Failed to connect to ctre

why i cannot connect to CAN and ctre and it give me this information

  1. List item

That message actually seems to be the CTRE lib telling you that it initialized successfully. If you aren’t able to control hardware, there’s a different problem - can you specify what exactly is your hardware setup, what you tried, and what happened?

5 motor controllers are showing up in one single ID. And how to specify the hardware setup

For configuring CAN IDs, you need to use the vendor’s config application - CTRE’s is Phoenix Tuner. Once you’ve initialized it, you can select a specific controller and change its ID. You can blink them to see which controller in the Tuner is which.

Hi. Here is the screenshot: it appears that they all come in one item instead of showing up as separate items. BTW, by “initialized it”, do you mean declaring and initializing it on VS Code? If so, I’ve already done that, but still not separating.

Just fixed. Thank you.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.