Falcon 500 - Calibration & Not Powering Up

Hi,
Yesterday, after clearing up our electronics, we tried to power our entire system to test it out. One of the Falcons did not show any LED indicators.

Upon measuring the voltage coming from the PDP, we are sure that the Talon FX is receiving 11.7 volts. This Falcon used to work well beforehand. We tried another PDP port as well. So, after checking out the user manual we tried to restore the calibration mode to default by holding down the CAL button without power and then powering the motor. This did not cause any changes as well. We are almost certain that the Falcon did not receive any physical damage during meetings and no software changes were made.

We isolated the motor from the CAN bus and applied power. Still, there are no LEDs blinking. Are there any suggestions or any other troubleshooting steps that we are missing from CTRE?

1 Like

If you didn’t already do so, check to be sure the polarity is correct (the red lead is at a higher potential than the black one).

We have tried and made sure the polarities are correct. Still no LEDs are lighting up.

We have 1 falcon (2 years old) in the same state. We pulled it completely apart and checked all the solder joints to the circuit board, etc. Put it back together, wrote “no blinky blinky” on the case and then chucked it in the trash. It’s the first of ours to fail (out of over 30), and considering the number of other motors we’ve gone through, it’s a pretty tiny rate of failure.

Is your falcon new, or older?

It was brand new, ordered in the first restock of this year. Will be contacting vex support if they have any solutions or offer any replacements.

You may want to check for a case short. There are some instructions from CTRE on how to check in the below linked post.