Falcon 500 inverts even after factory reset

We have a Falcon 500 Drive (not azimuth) Motor on our swerve drive that just started running inverted after the electrical team shortened the can wires.
We are using the onboard encoder for the drive motors.

We have tried the following to get it back but nothing has worked.
Here are the steps.

0: Connect to the motor on Phoenix Tuner
1: Set motor to factory default
2: Goto to control tab and select percent output
3: Select Force invert to False
4: Select Encoder Phase to False
5: Enable outputs
6: Send a positive output value to the motor

Motor blinks green LEDs
Motor turns CCW facing the motor shaft
encoder counts decrement.
We expect the motor to turn CW and increment the encoder counts.

We did the same steps on another drive motor on the swerve drive and it rotated as expected.

The motor seems to be stuck in inverted mode and even a factory reset does not seem to change it’s back to normal.

It there something else to try to get this motor back to the default setting?


Motor turns CCW facing the motor shaft

A non-inverted Falcon 500 motor is CCW+, so this is what I would expect.

encoder counts decrement.

This is not what I would expect, the TalonFX sensor position and velocity in code should be in the positive direction for positive output. Can you take a Self Test of the TalonFX in Tuner while driving the motor with positive output?

Thanks for the sanity check.
It seems the other motor was the one that was inverted.

So am I correct in Assuming that doing a factory reset removes inverts or does it only clear out configuration settings?

A factory reset does not affect inverts in Phoenix v5, as invert is not a persistent config. Phoenix Tuner has the ability to temporarily set inverts when using the control tab. Otherwise, invert is determined by the value passed into the setInverted() API in robot code (documentation here).