Falcon 500 Motor Drive Disabled

One of my Falcons is entirely limp on my robot. It shows up perfectly on Phoenix Tuner and I can enable it from Control/Use the motor Snapshot. Even when I max it on Control its totally limp. The error im getting is in the screenshot. Pressing the Clear Faults button dosent do anything about this problem. Has anyone else dealt with this before / how can this problem be fixed? All the other Falcons that are linked to it are working fine and ive tried it with fully charged batteries. Im also not getting any code errors in driver station.

Have you tried switching the power for that Falcon to a known working circuit?

Also, check the Falcon’s wiring very carefully. You could indeed have a short or a damaged wire that could be causing this. Examine them closely, then if you don’t find anything obvious do what @bovlb is suggesting and switch the Falcon to a power circuit that you know if working and, if that doesn’t fix it, try subbing in another Falcon just in case there’s a problem with the this Falcon’s own wiring. One of these things will give you the answer you need.