Falcon CAN Bus Issue

We have a falcon that has been working fine on our shooter for a while. All of a sudden, it has started blinking red side to side. We’ve tried removing all devices except this falcon, the RoboRIO, and the PDP with the terminating resistor. We still have the same problem. Regardless of where this falcon sits in the CAN bus, all the other CAN devices start blinking red. When we unplug this falcon from the CAN bus, everything is back to blinking orange. We have checked the continuity between the yellow and green wires, and they don’t seem to be shorting out. Yellow to yellow and green to green have a good connection too. The falcon isn’t showing up in the phoenix tuner under any of the configurations we have tried. All the other devices show up just fine when the falcon is disconnected from the CAN bus. Do y’all have any ideas for what we could try? We only have one spare falcon, and our competition is coming up in 5 days.

I recommend contacting Cross The Road Electronics. A team at Kettering #1 had this issue last week and, while I don’t know how it was resolved in the end, I do know that someone actually showed up at the event (he was in the area) to test the failing motor. They’ll take care of you.

We had this problem. Something about a possible internal CAN short to the case/bad internal CAN connection - was correlated to tension/strain on the CAN leads. Solution was to replace the falcon, unfortunately. Haven’t really been able to determine the root cause, CTRE is aware of the issue.

Ok, will do. We tried one more test where we plugged the falcon into the CAN bus while leaving it powered off. The rest of the CAN devices were fine until we powered on the falcon. Then the error reappeared.

Oh, specific to this: to the best of my understanding (and experience), CTRE devices generally have CAN passthrough when powered off (as opposed to sparks, which block CAN when power is lost) - the behavior you describe is consistent with this functionality.