Falcon Lag Issue

Hello everyone! I want to introduce a question concerning the lagging of our Falcons, and their programming.

Our elevator gearbox seems to jitter during movement. So, we disassembled it and tested the motors using the API and the Phoenix Tuner. When testing with the API at first, the motors jittered (feels like they stop for a brief moment, as if they were stopped in a single robot loop) randomly. After, we tested with Phoenix Tuner and discovered that when controlling the motors from the Tuner, motors stopped/lagged around every 15 seconds - in a somewhat constant time interval. To see if this was a common behavior of the Tuner X, we tried controlling a known-to-be-working Falcon from Swerve. Both showed the same lagging response. We, therefore, assumed this is expected or there is something else we are setting wrong. See below for the Phoenix Tuner self-snapshots and videos of the Falcons:

Also, the Slave Falcon, at first, didn’t follow Master - even in the case of a change in IDs - when it was set to follow from the API. When running the motors from code, (after testing it from the Tuner and factory defaulting), the motors both continued their lagging and produced ticking sounds in random intervals constantly. We suspect it’s because of the programming because we didn’t have constant lagging whilst the Phoenix Tuner trial. We will provide a video of this constant laggings tomorrow. These motors are on the CANivore with only 3 Falcons, so the CAN Bus utilization must be very low.

We also tried updating the firmware, power-cycling, and resetting the roborio, but nothing seemed to work. Below, you can also see the Driver Station Log Files, Driver Station screenshots, and our code repository (we are currently working on the master branch). In case of any solutions or ideas, we would appreciate it if you reached out.

Driver Station Log Files

2023 Season Repository Link - GitHub

3 Likes

Could you do a test where you have voltage being graphed? Our falcons jump up to 20v every so often and I am curious if this is the same problem.

The elevated voltage sounds like a regenerative-brake event.

The disable sounds like the roboRIO is disabling actuators for some reason.
I’ve seen that happen with certain driver station PCs in the past (firewall settings, network card settings, etc). Changing DS to a pristine PC and using USB may help rule this out.

Or roboRIO brownout events (I noticed a 6V event in your DS screenshot).

If you need to reach out to us: Contact Us

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.