Falcon500 not running issue

Falcon500 motor used in a non-FRC manner. Stopped working mid test run. Added the self-test snapshot below. Check the power supply no issues in that part.Need help

This device is on the default or non-CANivore CAN Bus
Motor Type: Brushless
Mode:0:PercentOutput | Output:0.00% [0.00 V]
Inverted: F | Drive Direction:counter-clockwise (positive), clockwise (negative).
Coast during neutral
VCompEn:F CurrLimited:F

PID0 (primary)
Feedback: Integrated Sensor
Pos: 274525u | Vel: -48u/100ms
Slot Select: 0
Err: 0 u | iacc: 0 u-ms | derr: 0 u/ms

PID1 (aux)
Feedback: Integrated Sensor
Pos: 274528u | Vel: -24u/100ms
Slot Select: 0
Err: 0 u | iacc: 0 u-ms | derr: 0 u/ms

Limit Switches

Integrated Sensor
Position:274528.000 units
Velocity:-24.000 units per 100ms
Absolute Position (unsigned):2026.000 units
On power cycle, sensor position resets to zero.
Units Per Rotation: 2048

Auto Zero Position Feature are disabled

(Fault) (Now) (Sticky)
Under Vbat: 0 1
Neutral Brake Curr Limit: 0 1
Excessive Under Vbat: 0 1

Motor drive disabled due to supply voltage spike below 4.9V.
Check battery and cable/power path. This can be caused by an
intermittent-short/electrical-arc/spark event in power harness.

I-Supply: 0.00A | I-Stator: 0.00A | Bus: 11.80V | Device Temp: 33C | CPU Temp: 37C

Nominal Output: [0.00, 0.00] | Peak Output: [-1.00, 1.00]

FRC Locked:0

“Light Device LED” clears sticky faults.

Build:Feb 24 2022 20:14:05
Press “Refresh” to close.

What is the power supply?

The power supply is a desk supply set at 12V and 40A CC limit. Sometimes hardware failure pops up in self test snapshot too. The shaft tries to move but couldn’t.

Have you experienced hardware failure with falcon 500’s before.

I would focus on this symptom. The motor reported a brownout and has a sticky fault set. So I think you need to reset the sticky fault to re-enable the motor.

Next you need to determine why your motor browned out. 40A should be enough current (depending on what load you have connected to the motor) but it might not be. If you have an oscilloscope you could monitor your supply voltage to watch for sag. (Perhaps the sticky fault is a remnant from an earlier wiring setup?)

Falcon motors do have a number of common failure modes that can cause internal shorts, and that could explain the brownout. Make sure the motor shaft spins freely and there is no grinding or play in the motor shaft. In extreme cases, you may need to open up the Falcon to ensure that there is nothing loose that has gotten into the windings or controller.

The exact issues you might expect with the Falcon will depend on which version of the motor you have. Motors sold since the start of this year are a big redesign from previous versions.

If you are still stuck, maybe posting some pictures of your motor setup, wiring, etc may help others to spot the problem.

1 Like

That’s nearly certainly the issue.

Any time spent running below 5500RPM will draw more than 40A. Presumably your test run will be hitting this at some point.

From there, it’s just a race to see whether the power supply’s CC mechanism or the motor’s brownout protection kicks in first. I would not expect that result to be predictable.

You’ll want a better power supply. Lead acid batteries are pretty solid for this use case.

  1. So how do I reset the sticky fault.
  2. Then the motor was on a test bench with no load and they were working fine and I was tuning PID for each of them with the same power supply. Have no idea how a brownout would have occured. Powersupply wasn’t shutdown all of a sudden. The other motor works fine but also has the similar kind of warning where it says “Voltage level below 6.9V” but still the motor runs.
  3. I purchased them exactly before a month. And sorry I’ll only be able to post some pics tomorrow. The shaft in fact spins freely and there isn’t much play in the shaft and remains as same as the amount of play when received.

Thank you for you help! Really appreciate it.

But then the motors weren’t even on load. They worked fine for like a week with a even smaller power supply a 12V 5A one. They didn’t demand such amount of current too. The 40A would be the max current on load right? Sorry if I’m wrong.

Even then the motors were working fine with the same power supply earlier. - This is what pokes out a bit. I’ve even tired with a 80A supply the motors doesn’t seem to run. Just struggles to move and stops and this happens in intervals. Myabe an intermittent short could’ve occured?

you don’t need 40 amps to run it with no load

I must admit that I’ve never done this myself… our students take care of these details so well that I’ve been spared the pleasure.

Phoenix Tuner can be used to inspect and clear sticky faults. You can also do this programmatically through the API, but you did say you are using these in a “non-FRC manner” so I don’t know if that’s an option.

From some of what I’m reading, the sticky fault may or may not disable the motor from running.

I think even a momentary voltage sag could trigger a fault, so you might double-check you wiring to see if something is intermittent there. A 40A bench supply should have plenty of filtering, but it is possible that you are temporarily exceeding its capacity. You might try swapping a charged battery for the bench supply to see if the situation improves. Batteries have a much deeper ability to push current under duress.

But then the sticky faults doesn’t go away even if I clear them using Phoenix Tuner too. Could the falcon be damaged so easily? Even on no load.

All these statements seem like they are talking about steady state operation. I’m describing transient. I still haven’t heard a scenario where the transient behavior of the power supply is known, or were I am certain the power supply was not overloaded.

And to re-emphasize: as long as we are in a mode were there are two overload response mechanisms active, I would call it unpredictable which will trigger first, if either.

1 Like

Could you clarify: when you say the sticky faults don’t clear, do you mean they never reset even before you attempt to run the motor again? Or are the faults recurring immediately the next time you command the motor?

I think we’re past the point where we need more detail about your setup to be able to offer much useful advice. It would be helpful to know how you have everything mounted and wired, for starters. Also, more detail about the steps you’ve tried and what you observed at each step may provide valuable clues.

The power supply is definitely not in a overloaded state, I’m saying this cause I’ve been testing the motors running both simultaneously on no load. The power supply is sufficient even for transient periods when the motors starts. No CC noted, besides they were working earlier.

The sticky faults do clear, but then they re-appear as soon as i command the motor, I’m posting a drive link to a folder containing required details. If they are not sufficient please let me know.
Link - Falcon 500 - Google Drive

As for wiring and mounting please look into the drive folder. The only thing that I’ve observed is that the drive motor goes into this sticky fault condition once commanded and stutters to move also my power supply starts to CC.

What could cause this to a motor that was running fine earlier with the same setup?

Thanks for the timely replies and the help.

Ok, so to recap, you have an SDS MK4 module with V3 Falcons in a bench test setup running from a bench power supply. The drive motor is stuttering and browning out. This is confirmed by the fact that your power supply current limiting is kicking in.

I don’t know that we’ve isolated the problem to any one area. It could still be your power supply, your wiring, your code, a mechanical problem in the swerve module, or a failing motor or controller.

I would start by ensuring that the wheel can easily be turned by hand and that there is absolutely no binding in the module. Check for anything coming loose in the gearing, and make sure everything has enough grease. Even with loctite applied, we have found that it is a good idea to regularly inspect all bolts on our SDS modules, particularly during break-in.

Next, I would probably try a larger power supply, or even better, a battery. Rule out that you aren’t just temporarily drawing too much current as a normal state of affairs. (I honestly don’t know how much of a current spike is required to set an unloaded swerve drive wheel in motion.) If you can still brown it out on a battery that will tell you something.

The wiring that is visible in your videos looks neat and correct, but inspect closely for any tiny nicks or possibly bad crimps or connections. Damage to the wiring harness is probably the most likely culprit if this setup stopped working suddenly.

Finally, (and forgive me if you already tried this) you could try two experiments to rule out problems with the motor itself. First, does the motor still stall if you take it off the module and run it without any load? And second, does the problem go away if you swap in a different motor?

If the problem can be isolated to a failing motor, you may need to contact Vex to get a replacement.

1 Like

I’m confused

Neglecting inductive effects and motor current limiting, Around 250A. This will happen at least briefly, per vex’s motor charts.

Inductive effects will slow how quickly the current rises. Current limits in the motor may also keep it held back, but depends on how aggressive those limits are and how they are confgured

1 Like
  1. The swerve module is fine and doesn’t pose any additional resistance to motion.
  2. I’m yet to test it with a large power supply, will update once tested.
  3. Double check the wiring harness no visible issues there too.
  4. I’ve disassembled the module and tried commanding the motor, same stuttering effect.
  5. I don’t have another motor to swap in for the failed one, but I presume it would work.

Thanks for the help and I’ve ruled out some things. Yet to test with a larger power supply, But I doubt it might damage any internals due to abnormal amount of current draw. Similar to a DC short.

1 Like

–Working fine–
“No CC noted” state was when I received the motor and was working on a test bench with the same setup and same power supply.

–After the Issue–
Then CC condition started to occur as soon as one motor started to post brownout sticky fault with no load and the same power supply.

As far as my understanding, (I could be wrong)
The current activity the motors resemble a short circuit behaviour as observed in a self-test snapshot. My guess is probably one the MOSFETS legs is short to the winding within in the inverter part of the TalonFX. I’ve submitted an RMA form to vex robotics. Probably I’ll get a replacement or get it repaired.

Thanks everyone for the tips and help on diagnosing the issue.