Fast flashing RSL (200ms) issue

(Rookie Alert:D )
I have a crio-2/sidecar issue. No matter what I do, the RSL flashes at the fast rate. I can talk to it both thru the Dlink and with the crossover cable. I can reimage it with no problem, change dipswitches, deploy code (both the simplemotercontrol from the tutorial and robotmain), but nothing happens at the jaguars (flashing yellow always, which means no pwm) and the RSL continues to flash (yes, the jumper is installed, the flash rate matches the sidecar led).

when i start the driver station, it connects and gives me status on lots of things, but it says there is no code loaded and the robot, bridge and enet lights on the diagnostic panel switch between green and red.

I’ve reimaged the crio several times now with no errors. While it’s formatting and loading, no RSL, but after reboot, the RSL starts flashing immediately. Sometimes after reimage and reboot, I get a solid RSL for about 10-20 seconds (just long enough to get my hopes up) before it starts flashing.

FYI, this rig has never worked, we just put it together at the Jumpstart last weekend and our db-37 cable got destroyed when they tried to flip the connector around, so I just got a new cable Tuesday. It is possible that the reversed db-37 was connected up briefly on Saturday. Could that have damgaged anything?.

I’ve been through the control system tutorial many times now. I’m trying to contact a veteran team in town now to see if they can help, but I thought I’d post up here too. I am wishing for a spare crio and sidecar. If they weren’t so expensive I would have some on the way already.

The flashing sounds normal for missing code.
When you download code use a default project as-is, “build” and choose “Run as startup” to see if that keeps your Robot code light on.
When you get that lit successfully, you’ll still need to Enable the Driver Station before the Jaguar lights go solid.

As far as status lights go, make sure the Digital Sidecar power LEDs all bright green, and the cRIO status lights are all correct.

We are also having this problem. Have you resolved it yet?

Here’s one reason this might be happening. If you never download code persistently so that it runs on cRIO startup, and if you close your software development before you launch the Driver Station program, you will always see “no robot code”.

Make sure you’re not just deploying the robot code in debug mode. If you do run it in debug mode, make sure you don’t stop the code before you enable the robot.

In our case, we discovered that code that was changing the system clock rate (SetSysClkRate()) led to the problem. Removing the call to SetSysClkRate() made the problem go away.

It seems like some of the code in WPILib must be making assumptions about the clock rate. You may want to avoid adjusting the clk rate. :frowning:

Why were you changing the system clock rate?

We’re optimizing the kernel to achieve more processing power for other computations.

How did you get access to the source code to modify and re-build the kernel?