Fatal Java Error but only on some RIOs

When we deploy code, we get this error every cycle. All of our code worked and pushed onto a board bot, but as soon as we pushed to our RIO that was inside our chassis, we got the error, reformatted, firmware updated, but could not resolve the error. We then pushed the code to our board RIO, it worked, we put that RIO into the chassis and tried to push, but got the same error, when we removed both RIOs, they would not work or accept code. We then did a git checkout of previous code revisions until we got One a single revision from all the way back on the 29th that did work when we pushed code onto the, thought to be broken, RIOs. We have a slight idea that the problem is NAV-X related but I wanted to ask here if anyone else has had a similar problem or have any extra ideas about what the problem could be.

It would help if you could give us a screenshot of the error.

1 Like

Im looking in the log files to find it, It doesnt appear to load the error onto the log file, all i can see in the log is the "1 06:47.058 # 1 06:47.058 # http://bugreport.java.com/bugreport/crash.jsp 1 06:47.058 # If you would like to submit a bug report, please visit: " i should be able to screenshot it by Wednesday.

Also, how are you connected with each of your test steps? wireless? wired ethernet through radio? wired ethernet direct to rio? wired usb to rio? PC firewall disabled? other network adapters disabled (bluetooth/wired(if testing wireless)/wireless(if testing wired)/etc)?

we connected with every form of SSH to the rio with different PCs as well.

SSH is a software connection. I’m referring to hardware. How was it wired?

Also, the rest of my questions

i meant to type that as well sorry, we did connect with USB, Ethernet, and wireless through a radio and experienced the problem in all of them.


Did you confirm the firewall was disabled and all that stuff?
Relevant docs:

Other than that, I think we need to see the full output including the error message. A screenshot could work, but I’d prefer the actual text copy/pasted.

You mention that you think the problem is NavX related. Do both (all) the Rios you tested have a NavX installed?

When we were using the NavX, if you deployed code that attempted to initialize the NavX on a RoboRio that didn’t have one installed, it would silently crash. Comment out the NavX code and it would all work again.

At one point they did all have a nav-x on them. The rio that still works and drives code has a nav-x on it aswell

The firewall was disabled, and i did not disable any adapters while pushing, i did use Git Bash to do clean pushes though

This seems to be a potential solution? Does it work across all Rios if you comment out the NavX-using code?

we tried and ran into the same error

In a previous season, there was an issue w/the navX-sensor logging errors too quickly (the kind of errors that occur when the board isn’t present) and this would hang the RoboRIO. As of last year’s FRC season this issue was resolved. I believe the root cause of the problem lies elsewhere.

We figured out that we get this error when we don’t have at least one CAN device plugged in, we replicated the error on all of our RIOs and confirmed it to be CAN, however we do not know why or what causes the problem. We belive that it may be the 2020 RIO image, Rev’s vendorsdeps for CANspark max, or something in wpi.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.