Faulty Flash USB?


I’m new to the forums and excuse me if i post this in the wrong section, today i tried Flashing my 2010 ClassMate to the new 2011 firmware and it wont seem to work, sometimes it crashes right after loading the files (blue screen) or sometimes it starts and while it is in the script it seems to get an error and stop, then i need to start over again and the problems seem to stay. If someone could please help me it will be highly appreciated.

Thank you,

http://www.usfirst.org/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2011_Assets/Kit_of_Parts/How_to_Set_Up_Your_2011_Driver_Station.pdf describes how to properly re-image the Classmate. http://www.usfirst.org/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2011_Assets/Kit_of_Parts/Classmate_Update.zip contains the BAT file you should use to activate the Windows 7.

With my 2010 Classmate, attempting to boot the USB
flashdrive just gives me “A disk read error has occurred. Press
Ctrl-Alt-Del to restrart”

The thumbdrive itself seems to be fine (reads just
fine on another PC.) Other bootable USB thumbdrives
that I’ve created (.e.g to image the classmate before
attempting this update) work fine.

I have set the USB thumbdrive first in the boot order in the BIOS.
I’ve also tried using both USB ports on the classmate (I don’t
think that should make a difference though).

I have followed the instructions, for me it says the usb is corrupt?

and if your using the 2010 classmates then your usb should be the pop out one, not the swivel one. that will give you that ctrl+alt+del error, i used one of the teams we mentor and had that problem…
anyway i contacted FIRST US and am still waiting for a reply

The 2011 Image for 2010 Classmate USB stick is definitely
bogus. It’s formatted as NTFS even! (2010 was FAT32).
An existing post that I didn’t find until after replying here
fixed it for me:

I took the MBR from 2010 USB stick and put that on my
own 4GB FAT32 formatted stick and then copied the 2011
files to that stick. I used Acronis DiskDirector to copy
the MBR. There are open source/free ways to do this as
was well (although they tend to be more labor intensive/expert

oh ok, im now at acronis and i cant figure how to copy it =( could you help me?


It depends on the specific version of DiskDirector that you have.
For V10, you just right click on the disk and there’s a Copy MBR
item. Then on the target disk you can rwrite that MBR. For
DiskDirector 11 they seem to have removed this nice
feature and instead you have to “edit” the disk and copy
the right number of bytes representing the MBR. What a crock!!
That’s the sort of UI regression that’s a firing offense. But I digress :slight_smile:
Check the on-line help for the version you have and the procedure
should be documented. I had both V10 and V11 and used V10
to do it since it was dead easy. There are free trial versions
of DiskDirector. I’m not sure if this feature is enabled in the trial

I am having the same “disk read error” problem imaging our 2010 classmate. I have limited experience with imaging or mbr editing, so am hesitant to try this. Are there any other solutions out there?