FIRST Dashboard Awards Submission


I have submitted awards (Chairman’s and Woodie Flowers) for my team for the past couple of years but the FIRST Dashboard doesn’t seem to be working for me. I tried it yesterday and today hoping it was just my laptop. Every time I try to open up the form to submit the awards an error shows up on my screen.


I’ve tried reloading the page and clearing my cookies but nothing seems to work. I was wondering if anyone else is having this problem and if anyone can help me fix it? The awards are due tomorrow and my mentor and I are getting a little worried. I’m starting to think it’s just my wifi and it’ll work at home but I have no idea.

Thanks for the help!

Typically this problem shows up when the Lead Mentor hasn’t designated you as an awards submitter. Make sure that you’re checked off in the portal and it should hopefully work after that!

Otherwise maybe try using a different browser?

Alright, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.