First time with an Axis Camera, need help getting started

This is 3753’s third year as a team. Our first year the previous programmer wired the camera to our robot but didn’t use it as anything more than a decoration

So yesterday I tried to hook up our Axis camera to begin setting up our team’s first camera/aiming system, however without any lights on the camera, I have no idea if I have power to it or not.

I also don’t know how to check if the ethernet connection works fine.

There is a lighted ring around the lense of the camera-yellow while booting, green when operating.

You can test the Ethernet connect by browsing to the camer.
Have you setup the camera using the FRC camera utility?

Thats what I read but I didn’t see anything. Perhaps it’s because its the camera included back in 2011’s season (the M1011) or maybe I’m just blind

Here are some pictures I found.
Including one of the back where there are green power lights.

The back lights come on a couple of seconds after it gets power.
The yellow light won’t appear for 15 seconds.
The green light appears after 45 seconds.
Give or take.


Axis-M1011_Yellow.jpg
Axis-M1011_Green.jpg



Axis-M1011_Yellow.jpg
Axis-M1011_Green.jpg

How are you trying to power to the camera? Where are the wires to it coming from? If you aren’t getting any lights, it might be faulty. Was it ever connected to anything besides the dedicated 5 volt output on the Power Distribution Board?

thanks for the pictures! I was looking at the camera and didn’t see any lights on the front and became thoroughly confused… Couldn’t find any pictures like that when I googled it

As for the power source, when they tried to use it back in 2011, they severed the power cord from the wall plug so that it could be plugged into the 5volt slot on the PDP. However a couple of our wires have been a little iffy, and since I didn’t know where the lights came on, I’ve been confused if we actually had power to the camera or not.
Now that I have those pictures I can hopefully test it tomorrow and see for sure

Thanks for the help! Will post again if I have more issues setting it up

There should also be a small power LED on the backside of the camera, FYI

Both are vastly different in practice.

If you only want to use the camera for viewing on the driver station, all that is needed is to power the camera and connect it to the robots radio. Before you will see a picture on the driver station though, the camera’s ip and account info must be updated to match that on the driver station. This is done though a setup utility detailed in the section on setting up a camera here

If you want to actually process the images, you will most likely want to look into the Vision assistant provided with all of your driver station stuff. If you capture a photo from the camera (By opening 10.37.53.11 in a web browser on your driver station while the camera is operating on your robot), you can load the image into the vision assistant and try out different operations on the image. For example, if you are illuminating the target with green LEDs, you may want to filter out anything that isnt your green color to get the targets in your image and then detect blobs on the screen, effective finding where the goals are in relation to your robot (To be effective, you’ll have to do more, that was just an example).

We use Java, and for every function you do on the image, there is an equivilant “wrapper” in java for.

If you use labview, I think you can even just export the processing code directly for use on your crio.

Hope this helped and feel free to ask more questions. Also, search the white papers. There’s alot of good stuff in there.

Make sure the polarity of the power is correct. If it isn’t, you could cause damage to the camera. DO NOT PLUG THE CAMERA IN TO CHECK. Use a voltmeter to check that the plug has the proper polarity.

My teacher and I just tested everything with a voltmeter and the PDP is indeed giving 5.05V (from 5.0 to 5.1, so its good) and the polarity is correct (tested the wrong way too but still didnt work).
We tested everything we could think of and the wires ARE giving off the correct power. The camera lights still arent coming on. I plugged it into an ethernet to the clamshell as a last ditch effort but still nothing.

Is there any way to debug or attempt to fix the Axis Camera itself since we know the cables arent the issue, or should I just declare it broken and look for a replacement camera?

If you plugged the reverse power into the camera at any time, then the camera is toast.

Are you connecting the camera to a laptop using a crossover cable and setting the laptops ip per the instructions?

Had not tried that yet; wanted to just establish a power connection before i tried anything on the laptop. Will the lights not turn on if it’s plugged into the power supply but not my laptop?

Power light status ring should light up regardless of ethernet signal.

Based on your agreeing to the photos attached to an above post, Im guessing you’re using a M10 series camera.

Manual here: http://www.axis.com/files/manuals/um_m10_46940_en_1203.pdf

Anyway, it details the three LEDs on the back on page 8. Are any of these LED’s on the back (not the status ring or whatever, which the manual says the M1011 does not have) lighting?

The first picture in post #4 is of the power LEDs on the back of the camera.

Specifically, the topmost of the three LEDs is the power indicator and should light if there is any power to the camera regardless of settings.

Thats what we thought too and it is NOT lighting up when the power cable is plugged in, and we tested everything imaginable – the cables ARE giving power.
So I guess our camera is fried, and we’ll be ordering one tomorrow

Thanks for the help everyone

Was there any damage done to the camera prior?

I believe you said you reversed the polarity at one point, correct?

It cant hurt to open it up and see whats inside at this point if you’re about to junk it. Who knows, maybe there’s just a loose wire somewhere.

It’s an M1011 camera we got our Rookie year (2011), but we never really used it. So we have no idea how it wouldve gotten hurt before today, but yes in our efforts to get power to it, we did reverse the polarities, which didn’t work either. But yeah, maybe we’ll open it up tomorrow