flashing orange

we have an issue our victors are flashing orange we have no real electrician on our team and are trying to figure this out, any help would be helpful

Short Answer: They’re not getting a signal from the cRIO.

Long Answer: Check all connections. Ensure that you have the driver station up and running properly. Router needs to be on. Gaming adapter on. Make sure you set everything up properly per the instructions. Make sure you have code loaded.

yeah. check your PWM cables. OR check your code.

Yup, double check that the PWM cables are plugged in correctly (black wire on the inside) and all the way in. Also, make sure your driver station is enabled, not disabled.

also, in the code, make sure that the watchdog is fed. otherwise they will never stop flashing.
if you feed too slowly, the flashing will start again between feedings.

You might want to consider trying the FRC Diagnostic Window and check the Robot Signal Light status.




It is very easy to miss the internal connector on the Victor as you insert the PWM cable. It is easy to miss when the pins are slightly bent. When fully inserted the shell of the PWM connector will only have 1/8" showing above the shoulder of the Victor body.

We are having the same problem today. We have been loading our code successfully all build season and it has been working great. Today when we attempted to load the latest version none of the speed controllers are able to get a signal from the digital sidecar.

The Robot Status Light on the Digital Sidecar is solid during our code and when we run the FRC Diagnostic Window. But the victors are all still not getting signal. I have gone over every cable on the robot and they are all wired properly. This problem will not go away. We have deployed multiple versions of code with multiple computers and this is still not fixing the problem.

Does anyone have any idea on what problem might be?

So after 3 hours of trouble shooting we eventually reflashed the cRIO and this fixed the problem. However what we don’t know is what causes the cRIO image to fail like that. We think a programmer might have started deploying code while the robot was enabled and running, would something like that cause the image to fail?

If you mean deploying some code, then deploying another, self-contained, piece of code while the first piece is running, then no, this would not cause the image to fail horridly.

Were you trying to load code to RAM without undeploying first? This can cause weird results.