Flipped paths generated in PathWeaver

Our team is trying to implement the new Trajectories and Ramsete libraries. So far, we’ve successfully ran the RamseteCommand Tutorial. Our robot accurately followed the S path defined in the tutorial, in the right direction .

Then, we defined a similar path in PathWeaver (v2020.2.2) and then exported it. At first, we had a problem because our path didn’t start at the origin of the field. We implemented the solution from this thread and it worked !

However, the robot is actually following a flipped path on the robot left-right axis. We tried paths starting from both the red and blue alliance sector and both path were flipped.

We then tried generating paths parallel to the sector line, and those were flipped on the robot left-right axis too.

Once again, the robot follows the S-path from the tutorial (which isn’t generated by pathweaver) totally fine.

Thanks for the help !

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.