FMS discovery not working?

In Seattle and Calgary, the “DriverStation.getInstance().isFMSAttached()” method was not properly detecting FMS.

Documentation in wpilibj

     * Is the driver station attached to a Field Management System?
     * Note: This does not work with the Blue DS.
     * @return True if the robot is competing on a field being controlled by a Field Management System

I know we’ve been red before. It did not work when we were. Any ideas? Was this overlooked during a driverstation update or something?

By “blue DS” I believe they are referring to the 2009-style “little blue box” driver station, not the alliance color.

So then it should have worked regardless of our alliance?

We had some code that ran when isFMSAttached returned true this year that didn’t work at the Los Angeles Regional. We never had a chance to determine if it was the isFMSAttached or something inside, and ended up ripping it out.

I hope to play with it with FMS Lite during the offseason.


We did the exact same thing. I have a feeling it is something about the FMS.

We had a problem with the FMS where our joystick controls (we tried this with logitec joysticks and an xBox controller) were both reversed and backwards when connected and fine when not. What exactly do you need isFMSAttached used for?

To adjust what data to send on the smartdashboard for competition. Don’t want to get any lag.

We turned our camera LEDs on and off based on a dashboard button. We wanted to make sure they were always on at the field, in case someone forgot to hit the button.

Same here. Our code which ran the shooter wheel all the time when we were on the field didn’t work.

I just tested isFMSAttached with FMS Lite and it worked. Not sure if there is something different in real FMS.