FRC cRIO Imaging: Imaging Process Stuck on Rebooting

Hello, our team is trying to image our cRIO, and the process proceeds to where it says “Rebooting CompactRIO device” and stays at that stage for hours on end. We have tried using a different cRIO (we have 2) and the one we are using now is an 8 slot cRIO. We are using a crossover Ethernet cable, and we have all of the latest FRC and Labview updates. We are connecting the laptop directly to the cRIO. Helppppp !:ahh: :ahh: :ahh:

I had the same thing happen last night. I found that by disabling the Wi-Fi adpater the format went through fine the next time I tried.

I think my Wi-Fi was setup on the team subnet (10.x.x.x), so when the cRIO rebooted, the hardwired connection dropped and the WiFi become the next best route for IP traffic.

I agree. These steps were crucial for us.

  1. Disable wireless adapter on laptop.
  2. Configure ethernet adapter for static IP 10.##.##.5 and subnet mask of
  3. Use a crossover cable.

With this setup, we got past the “Rebooting…” stage and the image was extracted and installed.

Remember, the first time you deploy code after re-imaging the cRIO, you will have to perform a manual reboot.