FRC Drive Station help. No robot code!

Hello!
I’m totally new at the forum, so please be nice…
We’re having problem loading the robot codes to the cRio…
We’re using Windriver, C++…
We’re using an ethernet cable to connect to the cRio
here’s a screenshot
[spoiler]http://i438.photobucket.com/albums/qq101/tAp13_14/driverstationprob.png
http://i438.photobucket.com/albums/qq101/tAp13_14/IMG_8530.jpg[/spoiler]
Can you please give down any suggestions to fix our problem :slight_smile:
Much help is appreciated! :slight_smile:

I would try formatting the cRIO with the FRC 2012 cRIO Imaging Tool. When you do so, make sure that you select Windriver c++ as the option. Once you have done that, try compiling and deploying your Windriver c++ code to the cRIO.

Problem still persist :frowning:

Can you be more explicit about what the “problem” is? I see from the screen shot that the “Robot Code” light is red in the driver station. Is there anything wrong with the output from downloading the code? Similarly, is does the imaging tool complain at all?

Have you tried this?

http://www.usfirst.org/sites/default/files/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2012_Assets/DB37%20Ribbon%20Cable%20Assembly%20-%20Rework%20Instructions.pdf

Make sure firewall is off on DS computer.
Turn off wireless adapter on DS computer.

Has ribbon cable been checked for improper assembly? From the picture it appears that this is one of the cables that needs to be reworked. See article on KOP Control System web page. http://www.usfirst.org/sites/default/files/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2012_Assets/DB37%20Ribbon%20Cable%20Assembly%20-%20Rework%20Instructions.pdf

This would make no difference, as to only sending signals to the Digital Side Car. When you deploy the code is it loading onto to the robot? Are you using the YELLOW crossover cable? Are you sure you changed your computers ip to whatever it is suppost to be? Same with the subnet: 255.0.0.0? Turned off the firewall?

We fixed it it, thanks for the replies!

Great explanation on how you managed to do it!

yeah, it was actually the codes, we were loading the wrong codes…

Could you describe what you mean by the wrong codes? I am having a similar problem. Thanks. -Paul

Assuming that you are using C++, remember to reboot the robot each time that you load your code. (Java should do this for you)

Also, make sure to check that you don’t have an incorrectly assembled ribbon cable. That will cause a TON of really odd and inexplicable problems.

I think i know what tap13 was talking about when he said “we were loading the wrong codes…” as we had run into that problem before as well.

The problem was that we were sending the wrong file to the robot when we deployed code in WindRiver.

What we did to fix this was the following…

  1. open up windriver
  2. go to Window > Preferences > FIRST Downloader Preferences.
  3. change the file you download to the robot by clicking the browse button.
  4. navigate through the project you wish to deploy until you find the .out file. then click open. you should now have something like this…

C:\WindRiver\workspace\2012_Robot_Code\PPC603gnu\SimpleTemplate\Debug\SimpleTemplate.out

Please Note you have to build your project first in order for the .out file to appear in the debug folder.

Anyways, thats what we did when we had a No Robot Code error on our Driver Station.

Hopefully that works for you pmuller! :slight_smile:

Hi

We are having similar problem with Labview. Using the sample code to test the bench top setup and the dash board show no robot code. We have double checked the connections and the cable has been corrected. Any idea how to resolve this?

Thanks