FRC Driver Station - No Robot Comm

Dear CD,

I’ve been so busy working on 2016 drivetrain that I am finally getting around to some programming and cannot talk to the Driver Station.

The students have been successful at school but I took the day off to work at home and am stuck at having NO communication on the dashboard.

The cRIO is imaged properly. I am running a new wIN10 Laptop. I have turned off Anti-virus Malwarebytes and Windows Defender.

I have both a Ethernet cable and USB cable. I have changed the Team Number to either of the IP addresses and neither works (Communications and Robot Code remain red)

The only green dot I have is the Robot ( I don’t have the radio plugged in).

I’ve run this trap line for the past few years but am now stuck. I am reading the threads for clues but seem to be exhausted for ideas.

Next steps?

Use the USB cable and try browsing to to see if you can reach the roboRIO.
Then you can also verify the roboRIO firmware version, team number, etc.

On the Driver Station Setup tab, click on the down arrow next to your team number to see if anything is listed there that you can click on.


I can’t reach the RoboRio using Chrome because it is missing a plug-in and the new Microsoft Edge for Win10 does not work either. I tried downloading Firefox but Chrome gives some weird error.

I was able to see the RoboRio using the Labview roboRIO imaging tool.

THe target is roboRIO-3548-FRC, Current IP is and Current Image is FRC_roboRIO_2016_v19.

What should I try next?

BTW, thanks for your prompt assistance.


ALso the Team Number is 3548-frc( in the Setup, Gear Tab of the Driver Station.

I am pretty sure all Windows 10 computers come with both edge and explorer. Open up explorer and do it although Firefox does work better. Just curious What is the error you are getting when you try to download Firefox.

Image the rio with the v19 image. Before that though, you want to load in the respectable environment for whatever programming language you are using. Also before that we personally had to update the firmware. But, then can only be done from the browser.


I downloaded the base 2016 Robot Project again into the target and it started working. Strange. I had already down this before. It is working though.

Thanks for your help for now!

Sounds good. Have fun at home today!


Back to No Robot Communication again.

I am able to see the roboRIO-3548-FRC: System Configuration page using the Internet Explorer web browser (thanks Sperkowsky).

In the IP Address field in reads ( when just the USB cable is connected between my Laptop and the cRIO.

I lost Robot COmm after downloading to the target.


Will the Communications indicator on the Driver Station come back if you download an unadulterated 2016 Robot Project again?

Did it go away after you downloaded modified user code?

You can also use the browser to select “Disable RT startup App” on the main page and then hit the Save button at the top of the page.
You may have to scroll down to see the selection.
Then hit the Reset button on the roboRIO case and see if Communications comes back after the reboot completes.
That’ll just let you know if the user code is causing the problem.

Make sure to uncheck “Disable RT startup App” and Save again immediately after you’ve tested this.

I doubled back and downloaded the FRC2016 base code after rebuilding, deploying and running as startup and both comm and robot code are red.

I am using the USB cable and 3548-frc IP (

I disabled Malwarebytes and WIndows Defender (remained disabled).

I can read joysticks on the panel. I am running the Driver Station as admin.

I will bring the system to school this evening and have the students look at my setup.

This startup stuff is always so much fun, lol!

You can verify that the roboRIO firmware listed on the browser page is version 3.0.0f0

Are the status lights on the roboRIO front doing anything interesting?

I’d try with an older OS laptop if you can get one.

Let us know what it was if they get it working at tonight’s meeting.

No one mentioned turning off the Windows Firewall. For me, even thought he driver station is in the firewall, exceptions, I still have to turn it off for the driver station to communicate.

Brian K,

That was the issue! It took a while for the students this evening to figure it out but once they turned off the Windows Firewall it worked!

P.S. I will try at home soon!

Yea, good catch!
I always turn off firewalls, antivirus, and software update managers as a matter of course.