FRC Driver's Station No Robot Communication -

My team just got a new computer and we are having a lot of trouble getting our Driver’s Station to communicate with our robot. We imaged the radio, we ran the FRC Radio Configuration tool successfully, and we are able to deploy our code to our robot using the USB connection. Nonetheless, our Driver’s Station will not communicate with our Roborio (neither with a USB connection, or via wireless). And yes, we’ve added our team number in the Driver’s Station configuration tab – it’s still not working. Please help!

Make sure you don’t have any other driver station hooked to the robot. Other than that, go to the diagnostics tab on the driver station and check for the IP address it’s expecting(over wireless it should be 10.TE.AM.2 where TE.AM is your team number). Go to the RIO’s settings page using whatever computer can properly connect to it and make sure that the IP is that. If not, change where it says “DHCP or Link Local” to a static IP address. We’ve had similar issues where our radio isn’t DHCPing to our driver station and it needed to be set to a static IP.

Turn off network blockers, such as, firewalls, Defender, anti-virus software.

Look at the Driver Station Diagnostics tab for more information on the status of your connection.

Looking at the Driver Station Logistics tab, we noticed the “Enet” status light is not green. We’re also seeing the message “No operational ethernet adapters were detected”. How should we go about troubleshooting this?

Two different answers here-one for at home and another for at competition.
The lack of an Ethernet Adapter is probably because your laptop doesn’t have an Ethernet port.
Take a look at the laptop to see if you can find one.

The solution for competition is that you must have a USB-Ethernet adapter.
Once you plug that in, it will appear as an Ethernet adapter.

At home, if you are connected wirelessly, then you don’t need an Ethernet Adapter.
(Can’t use wireless at competition-and it actually will be disabled on the robot radio at competition.)

That screen does say that all three of your Windows firewalls are active and should be turned off.

Thank you – having our Network Admin turn our public firewall off worked

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.