Frc gamepad malfunctions


#1

Hey guys I was wondering if you could help me out. I’m part of the FRC team 6461, and we ran into a problem. Today the buttons A X B Y refused to work with the getRawButton command in Java. The axis would work fine, and the buttons would light up on drivers station so we know the computer could read it. And we also knew our pneumatics worked, which we wanted to use the buttons for.

Any advice is appreciated

Thanks


#2

What type of controller do you have?

I know some controllers have a physical switch that changes modes and remaps some button numbers, possibly causing that behavior.


#3

Logitech Wired Gamepad F310


#4

That’s really weird that it shows up on the driver station but not in the code. That means that the problem isn’t physically with the controller, so that’s good.

I’m guessing you’ve tried restarting the driver station.

You can also make sure the buttons are being detected by debugging how many buttons are on your Joystick or GenericHID object using getButtonCount().