FRC Radio - Bridge error

Hi Everyone,

We are from team 8505 and we are looking for any help/advice to configure our robot radio.

We have followed the WPI Programming Documentation instructions and have been able to image our roborio and load the firmware for the radio using the FRC Radio Configuration Utility (.exe). When we move to configuring our radio we get:
“Bridge Configuration Failed: Failed to change IP Address, please ensure the bridge is connected to this computer and try again”

Currently we have an ethernet cable directly from our laptop to the 18-24VP0E port on the radio, and power cable from radio to the voltage regulator module.

We are always running as administrator.

We received the same errors after trying the following things:

  • Disabled All other Networks (Bluetooth, Wifi) except the ethernet we are using
  • A different Laptop with an ethernet to USB adaptor
  • A laptop with a direct connection to ethernet port
  • A different radio and roborio
  • Using both PoE cable (orange) and ethernet cable
  • Using just the kickoff kit ethernet cables
  • Using new ethernet cables
  • Firewall has been turned off
  • Putting the roborio in safe mode
  • Putting the ethernet cable in the 802.3afPOE port instead
  • Reset the radio (no light change) and reset the laptop

And yet there the error remains.

We have checked many online resources, including the WPIlib documentation, several Chiefdelphi posts, and some reddit posts. I’m a new user, so I can’t link them directly here yet. Lastly, we called FRC support but nothing changed.

Is there anything else we should try?

I remember it being a common thing at competition and the solution was to “update firmware” (even though it’s the same one) when prompted, and then once the firmware was flashed to then try to configure the bridge. It’s been a while since I’ve had to re-program one, so I honestly forget if that error was also common on the desktop utility.

You’ve probably already seen my post from here, but have you checked if the radio is being configured by putting it in your robot? Our radio gave us the same qualms, but it seemed to have actually succeeded when we hooked it up. You can quickly tell if it worked based on the name of the WiFi network.

Yup we tried this many times - no luck.

1 Like

We just tried this. The firmware loaded properly and the same error message appeared. However, there was no wifi network with our team name or number.

An update to this post

Based on more online searches, we have tried

  • removed all the other USB ethernet adapters, so left with only one on Network Connections
  • disabled ipv6 (leave IPv4 enabled)
  • ping 5 10...1 (PING: transmit failed. General failure)
  • ping 5 (went through)
  • disabled firewall

Additionally, on the FRC Driver Station, the Enet (Ethernet) is turned on with “", as well as USB and Firewall are turned on with green light too. Everything else is off.

Just to check that everything is disabled correctly, we did netsh interface show interface:
Enabled Connected Dedicated Ethernet 2
Disabled Disconnected Dedicated Wi-fi

Lastly, we also enabled airplane mode.

After making ALL these further changes, the configuration still has not worked. Please help!

You’ve done a really good job finding known solutions and trying them. I assume you’ve seen this post and taken the steps suggested there? You best bet at this stage is probably finding a different PC and trying that…

Here’s another recent post on a similar issue, just in case you haven’t seen it.

Is this a school PC? We ran into that issue with all the school PCs, eventually one of the captains brought their laptop and configured all the radios successfully. Schools often put weird stuff on their PCs that prevent access to network settings (even as admin), using an untouched PC would be likely easiest.

1 Like

We have checked the first link and tried its provided solutions - no luck. The second link is not the same problem as ours.

1 Like

We have tried multiple PCs, none of which were from a school. All firmware and bloatware was disabled plus we ran everything as admin.

One more here. It’s a bit of a stretch, but the presenting symptom matches.

It may help if you find and post the log file written by the configuration utility, search for “wpakiosk.log” on the PC. The log file was pretty helpful in the above instance.

This may help, it helped me after a week of trial and error.

1 Like

Thank you so much for your reply. It took us some time to work through, but this is the exact solution we needed!

For others to reference, our problem was solved after consulting Known Issues — FIRST Robotics Competition documentation.

1 Like

You’re very welcome. I’m glad to hear it worked. Goodluck!!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.