FRC Radio Configuration 2017

We were able to load the new firmware to this years radio, and get it to configure correctly. The network would not appear however, and the wireless light never comes on. We also attempted to connect in wired bridge mode to no avail. Any ideas as to how to make it work? :confused:

We had issues with this as well. What worked for us was putting something in the (optional) Robot Name blank.

That worked for us too. Thanks!

There’s also an updated version of the Radio Configuration tool has been released that fixes this: https://usfirst.collab.net/sf/frs/do/viewRelease/projects.wpilib/frs.frc_radio_configuration_utility.frc_radio_configuration_utilit_2

We’re getting a similar problem. We updated firmware and configured the radio, but connecting to upload code or connect to the dashboard doesn’t work. We can connect to the network through the laptop but we can’t actually interact with the robot. Seems like the radio isn’t communicating with the RIO.

Hi, I’m having trouble loading the firmware to the radio. I’m following the instructions of this manual: http://files.andymark.com/OM5P-AN_QuickAP_Setup.pdf
It doesn’t connect when it displays “Listening on interface”
Any suggestions?

Did you follow R63?

Don’t use those directions.
Use the FRC Radio Configuration Tool found at: https://usfirst.collab.net/sf/frs/do/listReleases/projects.wpilib/frs.frc_radio_configuration_utility

And follow the directions at: Programming your radio for home use

We just recently had the same problem. What we did was download the radio configuration utility on to a another computer (We used a desktop) and it worked like a charm.
You could try doing that and hopefully it helps. I’m thinking it might be a windows10 driver issue because the laptop we were using was windows10 and that would not work. When it connected it to the desktop (running windows 7) it worked on the first try.
I contacted John Novak about the problem and his reply is as follows, “it happened to several at our workshop last week. my assessment right now is to try different computers. USB to Ethernet adapters failed and laptops need the WIFI totally disabled at the adapter level. even when I got it to work it took multiple tries. A desktop may be more likely to work”

We have also had issues running the configuration utility on laptops that have multiple ethernet adapters. We got it working by installing the configuration tool on a classmate drivers station.

(it seems the more ethernet choices the less % of being successful)

Does anyone have a working link to the radio configuration utility?
None of the links in this thread work anymore
thanks

This link is working for me:
https://usfirst.collab.net/sf/frs/do/listReleases/projects.wpilib/frs.frc_radio_configuration_utility

In order to successfully update the firmware to the OM5P-AC (this years access point), we had to use the Ethernet port on the modem next to the power plug.

This is different than the picture on the program.

The picture shows an OM5P-AN, which appears to successfully update with either port. The OM5P-AC appears to only work from with the ethernet port nearest to the power connector.

Note that the RoboRio should be plugged into the same port once it is configured.

Good luck!

It seems like most of the discussion is on Open Mesh Radios. I’m having trouble loading firmware to a d-link radio. I’ve followed all the on-screen prompts: connect to PC via ethernet and cycle power, but I keep getting the same error message: “Bridge firmware load failed: Timeout waiting for radio. Make sure you have launched the .exe not the .jar. Try using a switch. Please reset the bridge and try again.” I’ve followed all these suggestions, (except using a switch), but to no avail. I read somewhere that d-link radios are no longer supported. Is this true?

What firmware are you trying to load, and from where did you get it? The D-Link Access Point/Bridge is not legal for 2017 competition, and is not recognized by this year’s radio configuration tool.

What do you intend to do with the D-Link? It is probably capable of anything you need with whatever firmware it contains. You will have to configure it by hand, though.

I was trying to load firmware from the radio configuration tool, but it didn’t work, as you said. Also, I read that firmware is not intended for the dlink, only for Open Mesh radios. I managed to configure the dlink with the 2016 configuration tool, but wasn’t able to do the same with 2017 configuration tool. I intend to use the dlink on a practice robot, but if it can’t connect to a 2017 roborio, there’s really no point.

Actually, how would I go about configuring the dlink radio manually?

Try updating your drivers station and the other labview programs. Worked for my team.

I actually did it on my team’s test bed with the DLink Rev. A radio during the pre-season.

I wrote myself some instructions so I wouldn’t forget how I did it. You should be able to use these with very little modification, except for changing the 10.30.3.X addresses to something more appropriate for your team number.

Switch the radio into AP mode using the switch on the back.
Reset the radio by holding the button for 10 seconds, then waiting for the AP light (second blue one from the left) to stop blinking and then start blinking again. Power-cycle the router just to be sure.
Set your laptop to a static IP of 192.168.0.51 and a subnet mask of 255.255.255.0 and connect (Ethernet is best) to the router.
Connect to 192.168.0.50 in your browser and log in. The username is admin and the password can be left blank.
Set the router’s static IP to be 10.30.3.1 (that’s what I went with, you can probably use a different one) and the subnet mask to 255.255.255.0.
Enable the router’s DHCP server and make sure that it’s giving out addresses in the 10.30.3.20 to 10.30.3.255 range.
Make sure that the Wi-Fi network is enabled and give it a descriptive SSID (I put dlink, as opposed to 3003).
Save all your settings and power-cycle the radio.
Switch your laptop back to DHCP, disconnect the ethernet cable, and connect over Wi-Fi.
On the test bed, I have observed that the dlink network comes up faster than the RIO, which is a pleasant surprise after the OpenMesh’s 90 sec boot times.

There is a bug in the released utility, which prevents it from programming the D-Link DAP-1522 radios. Here is the 2017 radio configuration utility that can be used to program the old radios.

http://forums.usfirst.org/showthread.php?27052-2017-Radio-Configuration-Utility-with-DAP-1522