FRC Radio Configuration Application Bug: Error finding NPF device name for adapter (SOLVED)

OK, for those of you who haven’t tried to configure your radio yet with Version 19.1.0 of the radio configuration tool, let me save you a lot of heartache. First, there are some issues with WinPCAP and the latest version of Windows 10. So, the version that gets installed when you install the radio application is iffy on the latest Windows 10 release. In fact, that version of WinPCAP isn’t even being supported any longer. Using the Windows add/remove programs option and uninstall the WinPCAP that the radio utility installed.

Next, go to https://nmap.org/download.html and download the version of npcap you find there (I had npcap-0.99-r7.exe when I figured all of this out) and install it. During the installation, it will present a whole list of options, make sure that you select the WinPCAP compatibility option.

Once that’s installed, you’ll need to do another hack. The problem is that the GUI front end can’t pass the correct adapter number to the ap51-flash.exe that’s actually used to flash the new firmware. You’ll have two options:

  1. Go into your Device Manager (just search for “Device Manager”) and disable all network adapters except the Ethernet adapter you’re using to program the radio. To disable an adapter, right-click the adapter in the Device Manager and select “Disable device”. Once you have only the one adapter available, then the GUI will work. The problem is that the latest Windows 10 has a whole bunch of hidden NDISWAN devices that you can’t disable from the networking tools. They can only be disabled from the Device Manager. Also, make sure you disable the Bluetooth, etc. drivers as they will interfere as well.

  2. Alternatively, open a CMD window and cd to “\Program Files (x86)\FRC Radio Configuration Utility” and run the ap51-flash.exe by hand. To do that, first run ap51-flash.exe and note which adapter number is the Ethernet you want to use. Then:

ap51-flash

Example:
C:\Program Files (x86)\FRC Radio Configuration Utility>ap51-flash Error - no interface specified Usage: ap51-flash interface image flash router with given image ap51-flash -v prints version information One or multiple images of the following type can be specified:

  • uboot image * uboot image 2
  • ubiquiti image * combined image
  • combined ext image * combined ext image 2

The interface has to be one of the devices that are part of the supported device list which follows. You can either specify its name or the interface number.

1: \Device\NPF_{0756F82B-7206-4DEF-9185-06A8AB6B63ED} (Description: NdisWan Adapter)
2: \Device\NPF_{E4C04E84-9B4E-4E24-8765-3FC7EAAE44D0} (Description: NdisWan Adapter)
3: \Device\NPF_{B26327DE-D4A6-4940-A2D5-F5640821978E} (Description: Microsoft)

4: \Device\NPF_{3416F3C7-682A-4A9E-A282-F8B4218BA99A} (Description: Qualcomm Atheros Ar81xx series PCI-E Ethernet Controller)

5: \Device\NPF_{54CDC960-9E35-4800-9D4C-BECE4D3C40BE} (Description: Microsoft)

6: \Device\NPF_{A2D2E01B-59FA-4B4E-94A0-DCC9803AF9E4} (Description: NdisWan Adapter)

7: \Device\NPF_{AEE18815-00A1-4667-8196-03E4637C88F8} (Description: Microsoft)

8: \Device\NPF_{83A19222-18C4-41D6-84CA-ED17CC63C3EA} (Description: MS NDIS 6.0 LoopBack Driver)

For me, my adapter is device 4 and the firmware is firmwareOM5PAN.bin for my radio. So, the command would be:

ap51-flash 4 firmwareOM5PAN.bin

That will start the firmware programmer and wait for the radio to be powered on. Once it powers up, you’ll see a number of output lines as the boot loader and firmware image are loaded. When it completes, you should reboot your radio and plug into the other port (the one near the power plug) to run the configure from the GUI.

REMEMBER: If you went with option 1, remember to re-enable all of the interfaces you disabled via the device manager.

I hope this helps save everyone a lot of time. I burned probably 3 hours and when through 3 different laptops before I finally figured out all of the issues.

Good Luck,

Mike

6 Likes