Frc Radio Configuration

Computer IP is not being found while trying to configure the radio.

Have you gone through the troubleshooting steps here?

Also if you can please explain exactly what you have tried and give as much detail as you can on what is going wrong!


We have turned off all other adapters and still have Local Connection Area Options

Is it failing to change the IP address?

If so, read through the third issue and follow the steps to fix the issue.

2 Likes

So far no luck.
Went to the Known issues and used the 2020 wpi

Connected the radio with separate power and ethernet (no adapter)

Still unable to find the bridge

Can you show a screenshot of the disabled adapters? Do you have a VPN or other networking software?

I’m not sure disabling in the device manager is 100% equivalent to the process of disabling adapters in the documentation. Can you follow that process and show a screenshot?

It does look like you have a VPN installed. Have you tried a different computer?

networkconnections

1 Like

Should the power LED be solid or blinking (once/sec)?

It starts solid, but after a short time goes to blinking and stays that way. Connected to 12V 2A

Make sure the Ethernet cable is plugged into the correct port on the radio.

Also, try a different computer. Looks like you have some “fancy stuff” on that computer. If you have a USB Ethernet adapter disable the built in adapter and try that one.

My team has been running into similar issues over the last two meetings. No conclusive points to be made over here. Just noting that we are having similar issues.

We tried a different computer and it failed

Per Status Light Quick Reference — FIRST Robotics Competition documentation the power light flashing means it’s powering up.

Our team had exactly the same issue, and it was solved quite easily.
Are you trying to configure the robot through the POE injector?
If so, take the POE injector out, plug in the ethernet directly through the port, and supply the power separately through the power cable.

The students tried that one. They also tried using a different computer that has worked in the past.
Switched to a different bridge and getting the same results. Part of me wants to say it our methodology, but they’re reading and rereading the steps on the wpi docs…

If you are close to another team, it’s worth asking them to give it a try at this point.

1 Like

Haven’t heard back from my contact list. If anyone is available over the phone, we’d really appreciate it.

Wed Nov 24th at 7pm is our next meetup. Please PM if you can help then.

I’d encourage folks to keep throwing different computers at the problem. Last month, the following procedure worked for us on 1 of 3 PCs we tried it on:

  1. Starting with a new in box radio. (Note: the radio was not discoverable on any of the default IPs it was supposed to be on per the manufacturers literature)
  2. Disable all network adapters except the wired connection (Note: if the computer has a service running that automatically restarts disabled network adapters, then switch to a different computer. Just killing the service was not successful.)
  3. Set the static IP of the wired connection to 192.168.1.63 (Note, this is required to discover the radio. It’s something the radio config utility is supposed to do, but this element appears to be broken. Also note that we tried other IPs [e.g. 0.63, 1.10] but these did not work.)
  4. Run the radio config utility as administrator
  5. In the dialog box to select a network adapter, hit the refresh button and check that only the wired network appears. If so, then click ok.
  6. Hit the program firmware button and follow the instructions
  7. If successful, enter the team number and hit the configure button
1 Like

I suspect that this is the failed to change IP address known issue mentioned earlier in this thread. Did you try the workaround in the docs?