FRC Robot Radio not working

as far as I can tell The robot radio and the Computer aren’t communicating properly.
I configured the radio, and deployed the code to the rio, wired conection works, but I’m tying to get wireless to work.

image
this is what DS looks like now.

Looks like the radio connected.
I’d turn off all those firewalls on your PC in case they are blocking.

The bottom line tells me that you have firewalls turned on. Make sure to disable all firewalls (Windows 7 comes with 2 and Windows 10 comes with 3 default*) and anti-virus software, then try connecting again. Post with an update if it still isn’t working.

*Windows Firewall Private and Public, and Windows Defender for Windows 10

Edit: sniped
Edit 2: I could be wrong about this, but I believe having an IP address next to Ethernet means that your Ethernet adapter is enabled on your computer. You should also disable that when trying to connect wirelessly to the robot. Google how to disable your Ethernet network adapter for instructions.

all the firewalls are already off

i will be able to test later today.

I wont be able to test the radio until tomorrow, due to electrical work.

Something that helped us a ton this year was building a bench top electronics board. If you have the extra parts its great for working out all these issues before hand. It doesnt have to do much. Just a roborio, pdp, vrm, and maybe an old motor controller. Oh and of course a radio. This way you can test out these setup activities and push some basic code while the rest of the team works on your main e-board and robot. Wish we had done this years ago. Again only if you have enough extra parts. Good luck

resolved the issue, hidden firewall on a school computer

2 Likes