[FTC]: 0.0v on Ext Battery Problem

Ok so i recently updated RobotC to 2.01, and firmware version rfw.88 and got the new Tele Template from FIRST and I even tried the example tele-op Template in the example library to put our code into, and I know the code works. Recently whenever I Go to game mode in the joystick debugger to create my FCSconfig.txt the NXT window show the Ext. Battery as 0.0Vs and i know it’s charged what was the fix for this problem I know it’s happened before.

Thanks,
John Fogarty

I assume from the post that the TETRIX DC motors and servos are operating as expected (they respond to commands). The only problem is that ROBOTC is reporting a zero voltage.

I am fairly certain that last year’s ROBOTC firmware was only able to read the voltage of the external battery if a motor controller was the first device attached to NXT sensor port #1. ROBOTC will report zero voltage if a servo controller is the first device attached to sensor port #1 or if the controllers are attached to a port other than sensor port #1. I don’t know if this applies to this year’s firmware.

No actually the Tetrix Parts aren’t working at all the lights on all the controllers are on but nothing happens.

I believe that RobotC will not attempt to run the DC motors and servos if the battery voltage is too low.

How do you know the battery is charged? Have you checked it with a meter? At a practice session last fall, another team wanted to borrow a battery (or charger can’t remember which) because theirs was not working. It showed full on the charger, but would not run the robot. It turned out the fuse was blown in the battery cable. I replaced their fuse and everything worked fine.

i’ll try it but im preety sure the battery we used was good and the fuse was good

We should verify that the motor and sensor setup in ROBOTC matches the wiring on the robot.

  1. Please post a copy of your ROBOTC code.
  2. Provide a description of how the motor and servo controllers are wired. For example. NXT Sensor Port 1 is connected to Motor Controller 1. Motor Controller 2 is connected to Motor Controller 1. Servo Controller 1 is connected to Motor Controller 2.

Another thought. . . try replacing the cable between the NXT and the first controller.

I missed the post where you said the lights on the controllers were on (I am used to a mix of lighted and non-lighted controllers).

Micheal’s suggestion to verify the connection between the brick and the first controller is good. I would expand that to include verifying that all data cables are connected properly (fully inserted and in the correct order). I would also double check that all the power wires between controllers are good also. It may help to put the robot up on blocks, command it to move and then wiggle all wires plugged into the controllers to verify that you don’t have a loose connection.

I will see because i don’t know it that the problem because when the battery isn’t plugged in it registers OFF when i plug a battery in it registers 0.0v so i think it’s a code, firmware, config file, or Template problem because i remember seeing this problem before with RobotC 2.00.

There is a variable that contains the average battery voltage. If you are somehow overwriting that variable, this could be the cause. Have you tried running with an un-modified template?

must say i fixed it, i had the motor controller that had the batttery wired into it not plugged into the first port