[FTC]: Bluetooth Problem with LabView/FTC Controller Station

Has anyone experienced any problems trying to get the LabView FTC Controller Station to connect to the NXT Brick via Bluetooth? We have been able to run our bot with a tether, but are having problems with the Bluetooth Connection.

When we search for the Brick, the controller station finds it, but then when it tries to connect, the brick asks for a passkey, and when we enter the passkey, the controller station then says “Failed to Connect to NXT”…

Is there a way within the controller station to change security settings to not need the passkey or determine what the passkey is (if for some reason it is not what we think it is)?

We have been able to connect the NXT to the Laptop we’re using by using the same bluetooth dongle, it is only within the Controller Station that we’re having this problem…

Any suggestions?

Thanks in advance for any assistance!!

We had this exact problem. We are using a Mac (OS X 10.6) and this is our fix that, so far, seems to do the trick:

  1. Quit the controller station
  2. Open Bluetooth preferences.
  3. Delete your device from the list.
  4. Close Bluetooth preferences.
  5. Relaunch the controller station and scan for nxt’s.
  6. When you see your NXT highlight it in the list and the put a check in the “remember this device” box. (this seems to the the important part)
  7. Hit the “select” button
  8. Proceed as normal.

This has done the trick for us and I’d be curious to know if it helps anyone else.

So you have been able to connect to the brick via Bluetooth in LabVIEW but not in the FTC Controller Station?

Assuming you are using XP or Vista - delete the entry for your NXT in the Bluetooth manager for the OS (this is similar to what aklego described for Mac OS X), and try to connect again to the NXT with the Controller Station.

There is also troubleshooting information for Bluetooth and other FTC related items in the back of the FTC Getting Started Manual. Its worthwhile to check out if you haven’t already.


We had a similar problem with one laptop when we were at a demo over the summer. Our Vista laptop had no problems, but an XP laptop would not work (even with a brick that had worked in the past). Apparently the XP laptop had automatic updates enabled and one of the updates affected the Bluetooth. To correct the problem I had to go to services in administrative tools and change the logon for the Bluetooth Support Service to a Local System Account. I found this solution after an Internet search related to being unable to connect to Bluetooth devices.

The laptop was “connected” to the brick but was unable to use the virtual serial port associated with the NXT.

Let us know if any of these solutions work.

We had a similar problem. It seems that we could not connect to the brick with Labview and the control station running at the same time. Logging out of labview solved the problem.

This is actually expected (albeit annoying) behavior.

Can I ask you to confirm exactly which software you are referring to? Is it the one with the two pictures of joysticks which ships with LabVIEW, or the FMS, or are you one of the beta testers of the new FCS?


Ben, if you’re asking me, we are using the one with the two pictures of joysticks that ships with Labview.

Thank you to everyone for your advice, I’ve passed it along to my team and will let you know if we get it up and running today!

I just wanted to drop you guys a note and thank you for the help. By working with the bluetooth dongle, the NXT Brick and the controller station software on a different version of Windows, we were able to narrow this problem down to an operating system problem. We have someone checking into the updates (or lack thereof) on our team laptop, so this problem should be resolved when those updates are sorted out.

I haven’t been there for a few meetings due to other commitments, so this is second hand information. If people are interested I can unearth the specifics and post them…

Thanks again for the advice everyone!