[FTC]: FCS practice problems

My team is trying to setup an FCS for our practice field. We have the router setup just like the instructions said and we got the samantha to recognize the network but when we went to connect the fcs to our robot it does not come up on the list to choose from. When we checked the samostat on the nxt it said “Authentication Fail” I’m not sure what to do if you could help us that would be great.

FTC team 6095

From what I recall, you have to get the Samantha module the password for your network. In our case, we couldn’t properly communicate until we put a USB drive into Samantha, with certain data on it, and then powered it up. This was basically giving it the password for our network.

This was documented in with the Samantha instructions I believe. Try here: http://www.usfirst.org/roboticsprograms/ftc/samantha

yeah we did the the flash drive thing and the samantha light codes are saying that it is detecting the field network but on the fcs software our robot is not on there ?:confused:

Have you tried reinstalling the Samantha firmware? I don’t know if the Samantha module ships with the latest firmware, so that could be an issue as well. That’s the next thing I’d try if I had an issue like that.

Are you running security on your router? It’s possible that the security settings were put in incorrectly in the Samantha wireless config utility (that sets up your USB drive to be used on the Samantha). If so, you could double check that and/or disable the security on the router to simplify things. (and run the wireless config again + update the samantha again).

Thank you so much it worked! I didn’t even think about taking the security off lol. Thank you:cool:

Ok for some reason now it has decided to stop working again. I have no idea what to do we went to select it on fcs it said robot was offline. Then it finally let us select it but would not connect to the bot. So then i tried to reconfigure the samantha and now it still shows up on the fcs but it constantly says offline then the samantha’s wifi light isn’t even blinking. I want to try and fix it but if we can’t we want to try and find something else to practice driving.

Well, you can drive it via bluetooth if you have it installed on your laptop. However…

Please set up all your routers with the instructions posted here: www.usfirst.org/ftc/samantha in the “Samantha Router Configuration for Teams”. Make sure you include all security settings as listed in the document. I helped a team in Georgia with this issue a couple of weeks ago as they assumed certain aspects of the security without reading the manual. Security settings are very important including WPA2 and AES. If you can’t configure these items on your router, your router may not be compatible with Samantha.

Good luck and let us know what you did to get it working.

Can you tell us exactly what make/model router you’re using?

I’m 99% sure my team uses a older Linksys WRT54G. Once we got the security all figured out on it, it’s worked flawlessly since then.

The recommended model from FIRST these days is the Linksys E1200.

we are using the same older linksys the wrt54g and it worked at one time but now i am puzzled as to why it decided to stop working the second day we went to use it

Echoing Mannie’s earlier post, you should definitely check out the stuff posted by FIRST here: http://www.usfirst.org/ftc/samantha

We had a ton of issues with wireless connectivity at first, but now it works silky smooth. I remember the kids having to update the firmware on Samantha. We also had to configure the router with security settings, via that guide, and then run a setup program on the FCS so both sides knew the proper wireless security password. From there we would push the red button to ‘sync’ the devices, and then everything worked perfectly. Still does today.

You’ll get it working! If not, come post again and we’ll continue to help you. Best advice I can give right now is to get those FIRST guides handy and start everything from step 1.

Thank you we started over from scratch and it worked we have been running it for three days straight now. We are keeping our fingers crossed! Thanks for everyone’s help!