[FTC]: FMS competition issues

My team competeted at the competition at UT Arlington a couple of weeks ago and we had some major issues with autonomous. The night prior to competition we had a fully functioning autonomous segment of code with the field management system that is available for download. It worked flawlessly running autonmous and then switching to the teleop code. The next day at competition our autonomous did not work at all, initializing it the same way the night prior and also following the instructions given to us when we connected our robot to their system. Our code did not work at all with their system, but when we took our robot in the hall outside the competition area and ran the system with our laptop once again our autonomous code worked perfectly. Anyone have any ideas as to why this is? Has anyone else had a similar issue at their competition?

side note – there were only about 2 teams who had working autonomous code, but these robots would only move forward, all other robots just sat in the starting area during autonomous (like ours did).

Are you sure you had the proper version of the Autonomous code selected? Sometimes when you have multiple codes downloaded onto the NXT, it can get complicated and mistakingly an empty file might have been selected?

We ran the exact same code as we did when it worked. We started the same code manually both times, when it worked and when it didn’t. We also tried running it with only the autonomous code that did have code that worked and the tele-op program on the NXT but that didn’t work(not in competition at least)

Hm…Were any other teams at the competition having a similar problem?

This appears to be a continuation of a problem you posted in this thread:

Post #7 in this thread addressed this problem. Did you implement all of the changes suggested in post #7? Specifically, Items #1 & #2 explain why the robot would not move in a competition match after sitting on the playing field for a while before the FMS started the match.

Would you like to post your code again? Perhaps there is a new problem.