[FTC]: FTC Controller Station Connectivity (Bluetooth and USB) Issue

So I have a new NXT. The latest NXT firmware from LabView has been downloaded. The NXT will connect to NXT-G both by USB cable and Bluetooth. The NXT will connect to LabView by USB cable and Bluetooth.

But, the NXT will not connect to the FTC Controller Station by either USB cable or Bluetooth. I have tried rebooting the computer, turning the NXT off and on, removing the battery, and everything else I could think of. Has anyone else had this problem? Doe anyone know of a solution?

I haven’t experienced that before. Shot in the dark… have you tried changing the NXT’s name? If not, try changing its name and then connecting.

Also, what OS are you on?

I have had the same problem before. I would check out the FTC program training site: http://www.education.rec.ri.cmu.edu/content/events/ftc/ There is a video under labview thats called using the FTC controller station.

You can go under the program that you chose to use and view their tutorial on how to connect via BT. From the top of my mind, I can think of two reasons, one is that somehow you’ve got your NXT’s name wrong, and two, you are trying to connect a NXT-G controller station to the Labview’s firmware.

Anyway, I hope the video helps :smiley:

Make sure that you exit LabView or NXT-G before running the Controller station. Also, follow all of the steps laid out in the “Before coming to the field” posted on the FIRST website. You won’t want to connect via USB, but make sure that you follow the on/off power cycle when you switch from NXG-G/LabView to Robot Controller station (which substitutes for the FMS when you run it at school).

Thanks! For some reason our second NXT didn’t like being name 0177B; however, after changing the name we were finally able to connect to Bluetooth.

Adding a little more information. We had ax NXT named 0177 that connected with FTC Controller Station. We tried naming out second NXT 0177-B and then 0177B. It would not connect. When we renamed it another four digit number it connected. I tried this on two different computers one running XP and one running VISTA with the same results. It would connect with Labview and NXTG over bluetooth with all three names.

Okay, I hope this isn’t a red herring, so I’ll post a counter to this. I have three NXTs. Two of them have 1.21 firmware, the other has the latest ROBOTC firmware. The names are GA-FTC1, GA-FTC2, and 1004 (our showcase NXT). All three pair and work with the controller station just fine.

You might want to check other things out other than name. Meanwhile, I’ll investigate going the 1004, 1004-B, 1004-C route as well.