[FTC]: FTC Servo-Motor Problem with Labview

I’m using Labview 8.5.1 to try and run motors and a servo. I can run the motors alone or the servo alone, but when I combine the two, the motors buzz and the controllers are unresponsive. I started with the program from the FTC tutorial, but it didn’t work. I’ve also tried several other configurations, hardware and software, but always the same result… buzzing motors and no response from the controllers. The only configuration in which I could get a servo to work is when I plugged the servo controller directly into the NXT instead of the motor controller. Any ideas?

Also, is there anyway to run the servo with a button?

The order in which controllers are daisy chained determines their I2C address. Addresses are somehow automatically configured by the hardware with the controllers closer to the NXT having the lower addresses.

So, if you’re using daisy chaining, make sure the physical daisy chaining order corresponds to the parameters that are specified in the labVIEW (or NXT-G) blocks/VIs.

Also try non-daisy chaining and using two sensor ports: one for each of the two Controllers. You’ll have to make minor changes to the program for the “port” and “controller number” inputs. Once you get this working properly, thn you can try to convert to daisy chained arrangement.