[FTC]: Gamepad won't setup on FCS

When I get to the part where it says to press button 1 on gamepad 1 and I press it, it does nothing. The computer is running Vista 64. I’ve tried it with 1 and 2 gamepads connected.

Does anyone know what to do to setup the gamepads?

Have you properly installed the gamepads onto your computer with the discs that came with the pads? Just, is the computer recognizing that the joysticks are there.

If so, I believe you have to insert the controllers before you connect to your robot, and then when you go to recognize the controllers, they are already there.

Above are just some extremely basic suggestions. Hope they work.

First of all, the Joysticks that come with the FTC kit are Logitech Game Controllers and require no disks. The drivers come standard with Windows.

Now back to the original question…

My team is using RobotC so that is my knowledge base here… If you are using the Labview or NXT-G my help may be limited…

  1. Are you using the latest programming environment (v2.01 for RobotC) and downloaded the latest firmware to the brick (v7.88).

  2. Did you follow these directions successfully?

  3. Do the joysticks work without the FCS (in the programming environment)? In RobotC, you need to enable the joysticks via the debug Window.

Let me know…


I’m using RobotC to, we couldn’t get Labview working for awhile.

  1. I think so, I’ll check tomorrow. If it’s not where do I get the updates?

  2. Yes I did and it works.

  3. Yes it works when I use it in RobotC, are you saying I need to have the debug window open to setup the joysticks?

  1. http://www.robotc.net/ftc/

  2. Good.

  3. Good. No, you don’t have to have robotC open but I wanted to be sure that the basic framework is in place.

Speaking of frameworks… Let’s continue…

  1. Did you create a program for Autonomous and one for Teleop using the provided templates?

  2. Did you download both to the Brick?

  3. Did you create the FTConfig.txt file by setting it up in the Joystick debug window?

  4. Have you gotten Bluetooth working with your PC and robot?

Sorry for the interrogation but it’s the only way I know of to zero in on your problem.

Let me know…


  1. I have created a Teleop program and working on a autonomus program and I’ve used the templates.

  2. Yes

  3. Ummmmm, no, how do I do that?

  4. Yes.

lol 20 Q’s.

  1. The auto program is the program that your brick starts with. I think that it can be the same telop program but you will have no joystick control because the FCS starts in auto…

  2. Interesting response as you have not created the auto program yet.

  3. I’ll answer thi in a post in a few minutes. I need to see if I can grab a screen shot…

  4. Good.


Continuing with step 6:

Read this file to see how to create the config file.

Now that all this is done, you should have full game control from the RobotC > Robot > NXT Brick > Joystick Control - Game

I have attached a screen shot. However, yours should not have the “communications to robot is disabled” nor the “joystick controller mis-configured” error pop-ups (my NXT brick and gamepad are at school).

This window uses all the same protocols as the FCS.

Insure that you are in bluetooth (usb to brick unplugged) and that your auto program has been selected on the brick and the brick has been told to run the program via the LCD.

Insure that you can go from Auto ready to Auto running to teleop ready to teleop running over bluetooth and all of your programs are working correctly.

Now, get out of RobotC and start the FCS.

Hopefully, everything will work.



Game Window.JPG

Game Window.JPG


Some last notes:

It has been a few weeks since I verified FCS operation and I only did it once so my help becomes more and more fuzzy…

Make sure that the brick name in the FCS Setup is the same as the the actual brick name. It should be your team number. In my team’s case it is “0273”.

You change the brick name via RobotC > Robot > NXT Brick > Link Setup

Please let me know how you make out. I will be meeting with my team next Wednesday and can try and duplicate whatever problems you are still having.

Good Luck…


We are using a vista 64 bit computer and the gamepad is still not visible when we try to use the field control system. It is not an option to buy a new computer. Can anyone suggest a fix for this problem?