[FTC]: Labview can't use two controllers

I can get all the code running on one controller, but as soon as i add a second controller, it all stops working, I have installed all the patches, and have the latest firmware on my NXT.

I have tested the two joystick code on www.ftctraining.com and it did not work :confused: , when i use both controllers motors don’t work, but i can get a display of true vs. false from a button read. When I try to access only controller two it does not work.

Any suggestions would be appreciated.

Thanks,

Your post stated that you installed all of the patches from the www.ftctraining.com web site. This site has a pointer to three LabVIEW updates to on the National Instruments web site: zone.ni.com/devzone/cda/tut/p/id/7956

These updates are:

  • Motor and Encoder Update
  • Dual Controller Update
  • Sketch Example Update

Are these the updates you installed? Try re-installing the updates. The installation requires several steps and perhaps one was skipped. A copy of the installation instructions for the Dual Controller Update are at the end of this post.

Be careful when downloading the updates, this web page contains updates for both NXT-G and LabVIEW.

Michael


lv_ftc_2controllersfix Installation Instructions:

  1. Make sure LabVIEW is not running.
  2. In Windows Explorer, navigate to the folder where you installed LabVIEW 8.5.1. This is usually C:\Program Files\National Instruments\LabVIEW 8.5.
  3. Navigate to the …\vi.lib\addons\NXTToolkit\gcompiler\Backend.LEGO\Transformations\Register folder.
  4. Drag the LEGO.Register.GetSimpleFPLocalsRegisterSets.vi you extracted from lv_ftc_2controllersfix.zip into the
    …\vi.lib\addons\NXTToolkit\gcompiler\Backend.LEGO\Transformations\Register folder.
  5. Click “Yes” on the popup dialog asking if you want to replace the existing file.
  6. Now you will be able to use two controllers to control your robot. You will need to recompile your VIs to your NXT.

thanks, but i re-instaled the patch multiple times, and triple checked each step, still not working

Try installing the FMS from the www.ftctraining.com site as well and running your programs from the FMS. It should work the same as the FTC Controller Station.

Also, if you are using ROBOTC, make sure you check the Dual controller button in their debugging windows. If you don’t then both controllers act like one (I believe).

sorry for taking so long to respond, but i just got to test the FMS, still no luck getting two controllers to work, im using labview so it can’t be the problem with robotC, but thanks for the ideas.

and an update on the problem: i can get it all running fine on one controller, but when i use controller 2 it stops running motors, i can still get a print from an if statment useing buttons, but i cant run any motors or servos when running a second controller

thx for the help so far, any other ideas?

Can you post the .vi or a screen shot of the program. Maybe we can check that out for you.

This isn’t my code, but even using the basic two controller program from www.ftctraining.com site (http://www.education.rec.ri.cmu.edu/products/labview/nxt/ftc/teleop/programs/four_joysticks_with_servo.vi) i can’t get the multiple controllers at the same time, i can run a single controller fine, even when all i do is re-wire the inputs that access controller two into controller one it runs fine. I did make sure that all of the servers and motors were accessing the proper port and controller. On my other program i am using the template and same thing, doesn’t run with two controllers but works fine with one. Also i have tried with and without the sequence flow.

Ok, its all good now, i re-installed the update again, and it replaced a different file than it had been replacing before, anyway its now running perfectly fine, thanks for all your help

I am running into an issue trying to control 2 NXT bricks with one labview vi how do i split up the search NXT’s to control each one independently?