[FTC]: LABView Servo Problem

Our team is using LABView, and we cannot get the servos to function properly.

No matter how the servo is controlled(same controller as motors or seperate, using buttons or joysticks) it only moves a few degrees when the button/joystick is pressed. I have tried connecting the servo value on FTCMoveServos to a constant, anything from 0 to 255, but it only moves within those few degrees.

Oddly enough, on an earlier test robot that we made, the same servos and almost the same code worked fine.

Any suggestions?

While I’m not familiar with Labview, I can make mechanical suggestions.

  • Make sure that there is nothing restricting motion. I might look clear, but watch out for clashing metal, I’ve noticed that the metal needs to be cut away from the servo or else it’ll get caught on the clamp.

  • Make sure your wires are in properly. A reverse or improper wiring can either reverse the signal or short out the servo.

  • Make sure that your servo has the proper range of motion. For our bot, i had to make sure the servos were centered when i was attaching the device to the servo. If the servo is all the way to one end of it’s scope, then it will not move the full range of motion you expect it to.

Other than that, I think it’s a code problem.

Also make sure you are using the latest updates for LabView that deal with motors. I know you’re playing with servos, but the update will help you make sure that everything is on the same page. The updates can be found here: http://zone.ni.com/devzone/cda/tut/p/id/7956

Yep, got all the updates. There is nothing blocking it physically, and the wiring seems fine.

Can you post your code so we can try to debug it here?


From what I can gather from the thumbnail (the .vi would be more helpful) is that you are scaling the values from the left side and right side of the second controller (either x or y) - which is correct and the left side is controlling one servo and the right side is controlling the other servo (servo #1 and #2 I believe). Is that summary correct?

If it is, it appears that the code is correct. So, let’s look at the hardware. Is your 12VDC battery fully charged? Is there any kind of load that you are putting on the servos to stop them from turning? Are the two servos controlling one item and are they facing the same direction? If they are facing each other and connected to move a single arm or something, then they would be fighting each other?

If none of those answers lead to a solution, I would redownload the program to the brick and try again. If that doesn’t work, then I would reinstall the firmware, redownload the program, and try again. I know that doesn’t make sense, but it might just clear it out.

Good luck and let us know how it goes.

They ARE fighting each other. I didn’t think of that slaps forehead.

Thank you.

No problem. Glad we could help.

OH MAN. I had the same problem and I didn’t even think about giving you that suggestion slapsface.