FTC Romi files

I have a ROMI Robot I’m trying to get set up for FTC. However, the file doesn’t seem to exist for the PC/programming. It states no releases available:

Does anyone have the .APK they could send me?

Seems to be forked from https://github.com/FIRST-e4usa/FTC-Romi
And from there, it points to the doc at Romi Setup — FTC Romi documentation

Maybe try those places first?

1 Like

Thanks, I now have the APK From the FIRST_e4usa account. Appreciate the help.

My ROMI seems to be disconnecting after 1-2 seconds after running any program. I’ve looked and it seems to be an issue with firmware.

Going to try another version of WPILIb and see if I get different results.

Remember that you will need to image both the SD card for the Raspberry Pi and also the Romi (Arduino) controller board.

You will need an appropriate .iso file to image the SD card. If you are using a WPILibPi image, the Raspberry Pi is capable of flashing the Romi controller with compatible Arduino firmware.


I finally got it working today using WPILIb 2021.1.1 version for the ROMI.

The newer versions all drop the program after about 1-2 seconds.

1 Like

Hello, project author here. Sorry about the late response and the mistake in the documentation, I had transferred the project to another repository a while ago and forgot to update the link. I have now fixed that. That is interesting that the newer WPILib version does not work, I will take a look into that. For now I will update the documentation to indicate you must use the older version.

Appreciate the reply, I’ve had it working great for some time.

Thanks for the software!

1 Like

Hi, We are trying to flash to a ROMI with no success. Any Ideas?

It is really difficult for anyone to help you without more detail. Are you trying to flash the Raspberry Pi, or the Arduino? What OS or firmware image file are you using? What utility program(s) are you using to perform the flash?

Specifically, what steps are you taking to flash the ROMI, and what errors are you seeing? Attaching console log output of any error messages may help.

There are a lot of people here who can help if they have enough information to understand your problem.

Sorry about that,
We have 5 Romi bots arom the FIRST Grant and have them all working and coding for the NYC Duck Challenge on the 11th of Dec. Now we want to get 2 working using the FTC interface, so we can mentor the FTC teams with coding. However we have trouble getting the WPILIb 2021.1.1 to work. I got it going for a second and then it died. and when we tried downloading another versing to have a competition with both FTC abd FRC Romi bots. ideas what might be the issue?

No apology necessary. The best way to get a quality answer is to ask the right question.

I can’t speak to FTC specifics, but one thing to check is that you are using the same WPILibPi version that you used on your original Romis. You probably want to avoid the beta versions, at least for now.

Also don’t forget that in addition to etching an SD card for the Raspberry Pi, you usually need to flash the Romi Arduino with a compatible firmware image using a USB cable.

It is possible that your SD card got corrupted when the Romi dies, but it’s hard to tell without more details about what you mean by that. You could test the SD card by moving it into another Romi to see if it will work there or if the problem travels with the SD card. Or connect a monitor to the Pi and see if it is telling you anything when it boots.

if you already have a working Romi, it is also possible to make a backup image of the SD card from that system and then etch it onto a new card to clone an existing setup.

Thank you for that reply, we will be getting new SD cards soon! Also on the contrary we have been having problem in terms of finding the specific release in Github, all downloads we have seen so far are Beta related. Is there perhaps a link you may share please, thank you for your time.

The release builds of WPILibPi can be found here: (scroll down to find older versions.)

Hi @11110111011 and @Nolan1324,

We are also interested in trying out FTC-Romi, but there in no APK file in the Nolan1324 → FIRST-e4usa github linked above (Releases · FIRST-e4usa/FTC-Romi · GitHub).

I tried to build the APK myself using Android Studio, even though I have very little experience with Android Studio. When I finally get it to build and then try to run it on a virtual device, the app crashes and there is a logcat entry about:

java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.qualcomm.ftcrobotcontroller/org.firstinspires.ftc.robotcontroller.internal.PermissionValidatorWrapper}:

java.lang.ClassNotFoundException: Didn't find class "org.firstinspires.ftc.robotcontroller.internal.PermissionValidatorWrapper" on path: DexPathList[ ..... ]

The AndroidManifest.xml file has:

    <!-- The main robot controller activity -->
    <activity android:name="org.firstinspires.ftc.robotcontroller.internal.PermissionValidatorWrapper"
              android:launchMode="singleTask" >

but the FTC-Romi github actually has no “internal” folder (and thus no code) in
FTC-Romi/FtcRobotController/src/main/java/org/firstinspires/ftc/robotcontroller at main · FIRST-e4usa/FTC-Romi · GitHub.

Is there a trick to building the APK so that the PermissionValidatorWrapper will be included?

Even better, could you please re-release the APK on github?

Thank you for reading