[FTC]: Samantha connected, but not working

This is my first post so please let me know if I put it in the wrong place or anything.

I am trying to help a team with the Samantha module. I am trying to connect it through the field control system using a DIR-601B1 router. The Samantha is showing a solid blue light, slow flashing white, and solid red light. Below, I have attached a .gif of the LED code.

The FCS allows me to choose the robot, but gives me a red box that says: Not connected to 0B1934 at The robot appears under the choose menu, but does not connect. I have tried pushing the red pair button on the samantha module.


I uploaded the Teleop template code from RobotC instead of the team’s drive code. I also chose the teleop program in the program chooser.

Here is my router config page:


Here is my flashdrive config:


Here’s the Samantha led code:


I would really like to be able to wirelessly control the robot so drivers can get practice before competition. Any help/guidance would be greatly appriciated.

Which version of the Samantha Module do you have?

It is possible that the Field Control System is set to require a Samantha module that is a new version. If you go under the configuration tab on the FCS and it is at the bottom.

I have the Samantha Version 2

What size flash drive did you use to flash your robot. It needs to be smaller than 4gb

I used a 2GB flash drive, and when that didn’t work I tried a 1GB. Both in the FAT format.

I was reading through the manual for setting up the network and checked your network name. The manual says to call it FTC_FIELD is there a reason why you called it something different?

No I didn’t think the name would matter, because you can set it in the config tool. I just tried it as FTC_FIELD and got the same result. I’m beginning to wonder if my Samantha module is broken or something. I have followed a few guides and I get this same problem every time. I have tried another router, another NXT brick, different flash-drives, and different FMS computers. Thanks for looking this up. I’m inexperienced in FTC.

My team has had huge problems with the Samantha before. This was the first year where we were able to get it going in a day. I would suggest reading over all the materials that you can find old and new to see if you are doing something different than what it says. There are videos and other manuals out there made by FIRST to help.

Have you paired your Samantha to the FCS system?

Have you configured your FCS with the password?

I have not paired the Samantha with FCS. It has not prompted me to pair. I have pushed the red button a few times, but it didn’t seem to do anything. I assumed that I was having connection problems before getting to the paring step. When are you supposed to pair it and how do you pair it? Also, I’m not sure what you mean by configure FCS with a password. Do i put a password in somehow? Thanks so much for all your help!!!

The first step in the process to setup the Samantha is to set up the network using the Samantha Network Setup. Once you put the settings where you want you load the file to a flash drive. You also need to take the password you created and put it into the FCS. The password field is part of the configuration button of the FCS.

  1.   Make the USB(this was done eariler)
  2.   Start with Samantha powered OFF
  3.   Plug in USB Drive
  4.   POWER ON Samantha Module
  5.   Wait for Power-on LED Sequence (above) to occur TWICE
  6.   POWER OFF Samantha Module
  7.   Unplug USB Drive
  8.   Plug in NXT Cable
  9.   Power ON- WHITE LED should flash

When you connect for the first time a continuous light sequence of RED ON, WHITE ON, BLUE ON, RED OFF, WHITE OFF, BLUE OFF you should press the red button on the Samantha and they should be ready to go

This Webpage has the flash codes of the Samantha and it is where i got the list on how to configure the network.

How do I put the password into the FCS. Do you mean under the configuration tab in the FCS software? Also what password do I put into it? is it the same one as the wireless password? Thanks!

Yes you put the password in the FCS.

The password is the one that you used for the Samantha Network Configuration.

On Step 4 of the post from OrangMoore about the procedure, hold the Samantha reset button down before powering on the robot(and Samantha module). Wait until you get at least one white LED flash before letting go. The rest is correct.

Make sure the computer is connected to the WALT_FTC network before starting the FCS. Start it, (configure joysticks as appropriate), then search for the NXT brick by team number. After connecting to the Samantha module, you will be prompted to hit the reset button (ONCE!) then it will go to a solid white network LED.

hints from your friendly neighborhood FTA…

it looks to me like you are running the autonomous portion of the match in the FCS, but you didn’t mention uploading an autonomous prog to your brick. Is that the problem? Try turning off the autonomous portion of the match.

NOOOOO do NOT enter the password in the FCS. We accidentally did this in the configuration window and had to completely re-download the FCS to get the original password back. Make sure that the samantha.hex file is on the Flash Usb drive that you created and make sure that it is the one that came with your FCS. also, when flashing the samantha, make sure that two complete light cycles happen, then unplug the usb drive BEFORE powering the samantha off. When pressing the red button to pair the FCS with the samantha, press connect, then one short click of the red button is all that is needed. last, make sure that the program you are running is using the FCS competition toolkit (if made in labview). Hope this helps!

Thanks for all the help! It turns out that the wireless on my router was 11mbps and it should have been 2mbps. I now have another router that connects to the Samantha and works fine. Thanks again :]

Do you have documentation on other router wireless settings such as the 2 mbps that affect Samantha? I didn’t see anything in the documentation at usfirst except for wireless-b and the recommendation to use WPA2 personal.