Get a NetComm error opening a new default Labview robot code

I start a new robot project and go to build an empty project and get a slew of errors that have the following reason

Broken VIs:

    Sub VI not supported in current target

unless someone recognizes this I will uninstall and re-install…


We are having the same problem. Only we can put the program on the roborio2 but when we open the program again it is broken with these same errors. The NT Write String array in the 1st picture is where the error is located. The second picture is the root cause.

What target is selected if you click at the circled spot?


When we switch it to my computer the arrow is no longer broken. But, that does not help because we would just be building to the computer. So, maybe it is an error with the Roborio? However, we did not try the Main Application Instance. They are going to try to reimage the Roborio real quick

Well my theory was that my computer had been selected instead of roborio, but you busted that theory.

Do either of you have old versions of labview installed?

No the older version of LV was uninstalled before installing the new LV.

We saw this same issue on 2/5 of our computers* last week. Even more strangely, it seems to be project-specific. That is, we ported two different robot projects into the 2023 template — our nearly-default “test bed” and our very custom 2022 robot code. Only the “test bed” project has this problem. Since all of our development will be done in the working project, I guess it’s okay for us… but it does make me bit nervous that there is something we’re missing…

*everyone followed the same set of installation instructions, happy to share those if it helps debug

well…fwiw, I totally removed ALL FRC software and installations and started installing again. I do not have a RoboRIO to connect to t the moment but a quick build of a new Labview robot code completed without the previous incidents… just crossed wires in installation???

will update after I test with RoboRIO

I asked for help with this issue in an FRC discord. A person marked as working with NI is saying that this is an issue with LabVIEW that they’re forwarding to NI to be resolved.

1 Like

This is a pesky problem that seems specific to the 2023 software. I just updated one of our development laptops yesterday and we immediately began experiencing broken VIs when re-opening a project that had been working fine mere moments prior. A workaround is to create a new template project and then copy the sub VIs from the broken project into the new one. The new one will open without any errors - until the next time it decides to spontaneously combust. I haven’t yet found the specific conditions that trigger the bug, and I’ve had it happen in clean projects with minimal modification as well as established projects I’ve been working with for months. It’s really harmed our productivity.

It is hard to be sure, but I suspect there are several issues involved here. I will list a few conditions that can cause errors, and hopefully they will help diagnose what you may be running into.

  1. The game tools installer this year didn’t seem to do a good job of removing old files before installing new. The results was that you could end up with a mash of old and new files. If you never uninstalled gamed tools, perhaps it is worth removing and installing game tools. Your LV installation should be fine.
  2. Templates that shipped in prior years were built to target a myRIO product instead of a roboRIO. These are close-cousins, but now and then, it would cause the SystemExec to break the VI. This is the black >> subVI. New projects use a roboRIO target type, and you can drag files from old to new project pretty easily.
  3. Especially if Network Tables functions are busted, be sure that the target you are using is images for 2023 v3.1 or greater. This year’s NT is totally new and will not work on older controller images.

If you have other issues, please post the error from the broken arrow or build.
Greg McKaskle

We are still troubleshooting this issue. Other than trying different programs and getting the same broken programs when reopening, we reflashed the roborio 2 sd card, we tried multiple laptops. Today we tried using an old roborio and had no problems. Our next attempt is going to be trying a new microsd to see if that helps. However, after reading Greg’s post I am back to thinking it is a NI LV issue and assuming when they get the bugs fixed they will send out an update.
I will also have my programmer capture the error the next time we get it and post it on here.

Yes i too tried reflashing and installing updates. I did notice that i could run a new default robot project on the robot tethered to the roborio without an error but when i tried to build in prep for a deploy it started throwing broken vi errors and was corrupted from then on.

We have once again put the Roborio 2 on the shelf for a later date. We are running programs with no problems using the Roborio. If we have time, we will continue troubleshooting, but it may not be until after build season.

did your issue go away with the RoboRIO1 then?

We never had the issue with the Roborio 1. We originally put our electronics board together with the Roborio 2, but when we started running into issues we switched out to the Roborio 1 and had no problems.

note for NI in their trouble-shooting, we too pulled an older RoboRIO 1 off of an old bot, updated firmware and image to 2023 standards and it works fine…has to be something with the RoboRIO2, how we are preparing it (althought we feel we ARE following the WPI directions), or the images being used…


1 Like

We have had the same issue. We have one computer with the last year’s version of labview installed - no problem. The computer with updated labview (old version uninstalled) is having this issue. We also then switch back to a roborio instead of using our roborio 2.0 and the problem has gone away.