Getting REV Blinkin LED Driver to work, not detecting PWM signal

Our team is trying to get LED control with the new REV Blinkin driver.

We powered the device from VRM, connected the PWM cable to thr Roborio correctly, device has power and LED are working. We use 5V addressable and the Blinkin is properly set to 5V LEDs.

We program in Java Command Based, created a subsystem for the LEDs, programmed 3 different color using a Spark Motor Controller java class… and we have 3 different command, one for each color… assign each color to a specific joystick button and a we also write to the smartdashboard… up to that, everything is working just fine. When i push the coded buttons, the value on the smartdashboard changes to what they are supposed to…

We also tried a the PWM cable to a Spark Motor controller instead and it worked just fine… the LED on the Spark is behaving just as we expect it to based on the -1 to 1 value for each of the color coded.

Problem is when we connect the PWM cable (yes it is connected properly both on the Roborio and the Blinkin) the blue status light is still flashing, telling us that the PWM signal is not detected by the device.

We read and reread the manual, watch the overview youtube video and still can figure out how to make it behave the way we want…

Is there any team out there using the blinkin successfully? have you ran into any similar issues? and if so, how did you resolve…

Call REV and briefly talked to David, he suggested we power directly from the PDP instead of the VRM…


Our Blinkin is powered directly from the PDP and I don’t believe we have encountered the problem you described. We have had an issue with two different Blinkins where they occasionally don’t light up whatsoever, but “resetting” them fixes it.

You can reset the Blinkin by removing power from the device, then apply power while holding the mode and strip select buttons, and then our lights began to work again.

Will try tonight… hopefully thats all there is to it…

Sent from my iPhone using Tapatalk

Hi! I am currently experiencing the same issue and was wondering if you found a fix.

Thank you very much.

1 Like

A post was split to a new topic: Controlling Rev Blinkin from commands